
Manual WSAT program (2004.08).
Introduction.

This is the manual of wsat, the program to receive high resolution weather satellite pictures of NOAA
and Meteosat. Currently only the so-called "Rob Alblas decoder" is supported.
The HTML-version of this manual is interactive: click on a menu item to jump to the description of that
item. 

Starting the program.
wsat may be started by clicking an icon, by means of a command shell or by means of a script (e.g.
autoexec.bat). In the last case automatic recording is possible. 

Usage: 

  wsat {options} [file]
       {options}:

         -i <file>            read <file>
         -sn                  south-north (flip hor and ver)
         -w <width>           Window width (default: 400)
         -h <height>          Window height (default: 300)
         -record <sat:chan>   Auto-record; exit program if done
           <sat:chan>         specify satellite and channels
           <sat>              hrpt | chrpt | hri
           <chan>             1-5, a, g (hrpt)
                              1-0, a, g (chrpt) (0=channel 10)
                              g (hri)
                              a=all channels
                              g=generator mode (only usefull for test)
          -crecord <sat:chan> Same as -record, but record ’forever’
          -batch <sat:chan>   Batch-record; exit program if done.
                              Same as -record, except no graphical mode.

          -cbatch <sat:chan>  Same as -batch, but record ’forever’

          -log                batch messages in wsat.log in 
                              home dir. instead of in shell
Examples:
         wsat                     start wsat
         wsat ned.gif             start and read in file ’ned.gif’
         wsat -record hrpt:124    record HRPT channels 1/2/4
         wsat -record chrpt:1290  record CHRPT channels 1/2/9/10
         wsat -record hrpt:a      record HRPT, all channels
         wsat -record hri         record HRI
         wsat -record hrpt:ag     record HRPT generator mode

Note: See Interface preferences: Select hardware for automatic switching of the decoder to the right
type. 



More about commandline options.

-record: wsat gui starts in record mode. As soon as the decoder gets in-sync recording starts. If the
decoder gets out-of-sync recording stops and the program exits. 
-crecord: Same as -record; after decoder gets out-of-sync recording stops, but program doesn’t
exit. It waits for next time decoder gets in-sync and starts recording again. So, in this mode wsat
records forever.
Stop this endless loop by clicking on the ’Stop’ button in the Record HRPT or Record HRI
window. 
-batch: Same as Record, but without a gui. Messages are printed in the command shell from which
wsat was started, or in a log file. 
-cbatch: Same as batch, but program doesn’t exit; it goes on ’forever’ (as with crecord). Stop by
using e.g. the kill command (Linux) or kill.exe (windows) (or reboot ;-)) 
-log: Batch messages are logged into a file (appending). This file is ’wsat.log’ in $HOME (Linux)
or in the top-disk (Windows, e.g. C:)
Note that for Windows you need the -log option always if you want to see any messages! 

Overview program; main menu.

 

Menu: File.



 

Open.

Open an existing picture file: 

Select a directory: 
Double click on a directory name in the left list 
Or change the directory name in the ’Directory’ entry part. Every time you type a dir.
separator (’/’ or ’\’) the directory list will be evaluated and the file list in the right list is
updated 

Select a file: 
Double click on a file name in the right list 
Or select a file (1 click) and then click ’OK’ 

To restrict the amount of listed items: 
Change ’Filter D’ to restrict the amount of listed directories 
Change ’Filter F’ to restrict the amount of listed files 



 

Delete a file: Select a file, then press ’Delete file’. 

Close.

Close current file. Normally ’wsat’ only closes a file if a new file is selected for viewing. If a file is first
viewed and then has to be renamed or deleted outside ’wsat’ (e.g. with a file manager) the file has first
to be closed. 

Save as.

Save current picture. 

File types supported: 

HRPT (dedicated format) 
HRI (dedicated format) 
PGM (standard monochrome format) 
PPM (standard 3-color format) 
GIF (compressed lossless format) 

Note that for translating HRPT into another format (GIF, PGM, PPM) information is lost (10 bits --> 8
bits per pixel). 



The luminance settings are used to determine which bits are selected: 

Lmax bits saved 

> 511 9 ... 2 

<= 511 and > 256 8 ... 1 

< 256 7 ... 0 

Zoom in if a part of the picture has to be saved. 
Make sure that Lmax in luminance settings is OK, if translating from hrpt to other format 
Select file format. 
Select channel(s) to save (only if in and output file are both HRPT format). 
Determine file name to generate: 

Click on ’New name’ to generate a unique filename (normally not needed) 
Change the filename in the ’Save to’ entry box if needed 

Click on ’Save’. (You will be warned if the file already exists.) 

 

If filetype PPM is choosen and, at the same time, the View->Channel_map is active a color picture will
be saved, as specified in the View->Channel_map window. Also, alignment is done, if desired.
Example:
To save a CHRPT picture in color: 

Select View->Channel_map 
Click on Auto color to load mapping of 3 channels onto RGB 
Click on Auto align to align the channels 

Click on Lum threshold to get a better luminance range 
Select File->Save as 

Click on PPM 
Click on Save 

Note: Don’t exit the View->Channel_map window before saving the picture. (Iconizing is, however, no
problem.) 



Sat info.

Information about the current file s shown. For HRPT and HRI files the frame header info is also shown;
by clicking on ’Prev’ or ’Next’ info in a header of a certain frame can be eximaned. 

 

Load Kepler.

First a Open file window will be shown. 

Select the desired NORAD 2-lines Kepler-file. 

Now the ’Select satellite’ window pops up. 

Select the derired satellite. 
Check the "Diff start & Kepler ref. time" to see that the Kepler data is not too old. 
The shown number is the difference between record time and reference time of the selected
satellite, in days. 

Advanced: show/change the Kepler-elements. 
Redraw show the new grid ("grid" should be activated). 
Save: save the new settings (times and Kepler elements) into the HRPT-file. 



 

Quit.

Exit the program.

Menu: Edit.

 

Menu: File header.

Change some items in the file header. 

Satellite name: 
Search frame info Search reliable frame header 
Use it copy the found satellite name 
Edit name Change satellite name if needed 

Scan direction: 
Select satellite pass direction: nort->south or south->north 

Save: Save the changed items into the file. 



 

Kepler.

Change orbit/kepler data manually.

Extract:Extract start-time from satellite data. 
Click on Search time. The fields below show which line is used and the satellite name. Click
again on Search time if derived time seems unreliable. 
Click on Use time to load/use the extracted time. 

Select:Choose which time to use: the computer-time or the time transmitted by the satellite. (Note:
In the last case the year is derived from the computer time!) 
Redraw: Show the new grid ("grid" should be activated). 
Undo: get previous settings. 
Reload: reload orbit/kepler settings from the HRPT file. 
Save: save the new settings (times and Kepler elements) into the HRPT-file. 
Exit: exit the window; settings will be kept. 
Cancel: exit the window; settings will be lost (except if saved into the file). 



 

 

Preferences.

All preferences are saved in a file called .wsatrc. This file is read at program-start. 
By means of the Preferences window the preference items can easily be changed. 
(The .wsatrc file is ASCII, so may also be changed using a text editor.) 

The .wsatrc file is searched for in the following directories, in this order: 



multi-user O.S. (Linux/Unix): 
1. Start-up directory (for special settings) 
2. Home directory (for user specific settings) 
3. Program location directory (for default settings) 

single-user O.S. (Windows): 
1. Start-up directory (for special settings) 
2. Top-directory of current disk (e.g. C:\, D:\ etc.) (for more common settings) 
3. Program location directory (for default settings) 

The first .wsatrc-file found is taken. 
If no .wsatrc file is found the built-in defaults are taken. 

After changing items: 

Press Use to make changes effective 
Press Save to save changes in the .wsatrc file 

Changes will always be saved in a .wsatrc file in the current directory. Move it to one of the mentioned
locations, if desired. 

Main window position and size

Window position: 
Default: Position of each window is determined by Window manager 
Smart: Position of each window is such that windows don’t overlap, or overlap is minimal.
Main window is placed in upper left corner. 

Main window size: 
Width and height of window at start-up. Note that by pressing ’m’ on keyboard the window
size can easily be toggled between full screen and original size. 



 

Decoder interface

Parallel port selection: 
Choose port 1 or port 2. 
Select ’Fast parport access if all 10 CHRPT channels needs to be recorded. 
NOTE: "Fast parport access" needs a change in hardware: the ’Readyn’ signal has to be
delayed. This mode will not always work properly. The delay of readyn needs to be more
than the delay of the slowest data pin; if this delay is too big the par. port will be too slow to
record all 10 CHRPT channels. 
If just HRPT, HRI or max. 8 channels of CHRPT needs to be recorded then don’t select this
mode. 

Select hardware: 
decoder/genrator: Selecting decoder/generator will automagically also switch the hardware
between decoder and generator mode. 

Switch SM is not needed (remove or leave open). 
The decoder type (HRPT/CHRPT/HRI) has to be selected by means of switches on the
hardware (SD and SX). 

decoder type: Selecting HRPT/CHRPT/HRI will automagically also switch the hardware
between HRPT and CHRPT or HRPT and HRI. 

Choosing between decoder and generator has to be done using a switch on the



hardware (SM). 
Also, the HRPT/HRI pair or HRPT/CHRPT pair has to be selected by means of a
hardware switch (SX). 
Switch SD is not needed (remove or leave open). 

NOTE: This mode needs a small change in the hardware: D9 needs to be connected to R12
instead of to R11. 

 

Working directory and Kepler files

Working directory: 
Directory to which recorded files are written.
This is also the directory activated after selecting ’File Open’. 

Kepler file: File and place of this file used to load Kepler data after recording. 
Directory in which to search for NORAD2 Kepler files. 
Name of Kepler file to open. 



 

Record related settings

HRPT Record times: 
Start after: #frames while decoder is in-sync after which recording is started. (6 frames = 1
second.) 
Stop after: #frames while decoder is out-sync after which recording is aborted. (90 frames =
15 seconds.) 

HRPT filenames: 
base name: Base name of the file. 
Extension: File name extension. 

These names are used to generate unique filenames: 
{basename}{number}{extension}
In this example the generated filenames would be: 
hrpt01.dat 
hrpt02.dat 
etc. 

HRI Record times: See HRPT Record times. Except: #frames per second is 57. 
HRI filenames: See HRI filenames. 



 

Algorithmic

Define linearize on or off at start-up 
Define fixed-zooming factor for: 

short-key ’i’ and ’o’ 
ctrl-key in combination with mouse 

Define speckle-limits for despeckling: A speckle is detected if (in shown example): 
Sur. U-limit: value difference between surrounding pixels < 20 
Pix. L-limit: value difference between surrounding pixel and examined pixel > 10 

  U
L P R
  B

In other words: If the pixels U, L, R and B have luminance differences of less than 20, and at the same
time pixel P has a difference of more than 10 with the surrounding pixels then pixel P is detected as a
’Speckle’. Its value will be changed to the value of pixel D. 



 

Colors and fonts.

Font size: Size of fonts of all windows/menus/buttons etc. Default: 120. 
Grid color: Define the color of: 

HRPT grid (longitudes/lattitudes) 
HRI grid (land markings as transmitted by Meteosat) 



 

Menu: View.

 

Sat direction Choose satellite direction: from south to north or from north to south. 

Grid Activate lon/lat lines for HRPT or grid for HRI. 



Invert Invert picture 

Temperature Make temperature mapping (IR-channels only). 

Linearize Linearize HRPT picture. 

Despeckle Despeckle picture. See Preferences for some important settings. 

Skip faulty lines Skip faulty lines in HRPT or HRI pictures. The faulty lines are replaced by the
nearest line which is OK. This is done by a flag present in HRPT and HRI files for each line,
indicating if the decoder was in-sync. 

Palette Choice between palette present in file and grey-palette.

 

Luminance Change luminance mapping.
Press left mouse button near a green line and drag it. 

Lmin:Enter lower threshold. 
Lmax:Enter upper threshold. 
Redraw: Show the new luminance mapping. 
Lum thr.: Automatic luminance setting. 

 

Channel mapping Combine several channels. (Only works for (C)HRPT and Seawifs.) 
ro/go/bo = red/green/blue offset 
r/g/b 1/2/3/.... = contribution of channel to red/green/blue 
Redraw:Show new mapping results. 
Auto color:Automatic settings for CHRPT/Seawifs true color pictures. 

HRPT NOAA <=14: red=channel 1, green=channel 2, blue=channel 4 
HRPT NOAA >=15: red=channel 3, green=channel 2, blue=channel 1 
CHRPT: red=channel 1, green=channel 2, blue=channel 7 



Seawifs: red=channel 6, green=channel 5, blue=channel 2 
Align settings:Show/hide align buttons 
Auto align:Align CHRPT channels. 
Reset align:Reset all align-numbers to 0. 
Exit:Exit this window. 

 

Menu: Zoom

 



shortkey function 

z Zoom; click on 2 opposite corners of virtual rectangle 
(right-mouse button: cancel) 

Z
Zoom fixed; move rectangle to part of picture in which to zoom anc click 
(right-mouse button: cancel) 
(See preferences to change fixed-zoom factor.) 

{Ctrl} Zoom fixed; see ’Z’

f full picture (zx=zy=1) 

i zoom in fixed (default: 2x; see preferences) 

o zoom out fixed (default: 2x; see preferences) 

l last (previous) zoom 

c dx->dy: Make pixel-size dx equal to dy 

C dy->dx: Make pixel-size dy equal to dx 

zx->zy: Make zoom-factor zx equal to zy 

zy->zx: Make zoom-factor zy equal to zx 

Change zoom vars manual.

 

Menu: Luminance threshold.

Calculate "ideal" picture mapping on grey palette. 

Menu: Record.

See preferences to define parallel port and fast par. port access.



 

HRPT

Channel selection:Choose 1 or more channels to record. 
Sat type:Choose the satellite to record. (NOTE: You have to make sure that the selected sat-type
on software and hardware is the same!) 
Record mode:Choose decoder or generator. (Not present if deocder type is switched instead of
decoder/generator; see preferences.) 
Show during record: 

Select the channel to show on screen during record. 
Select the scan direction This selection will also be saved in the recorded file. 
Select amount of lines per screen. This is the amount of lines needed to fill one screen; next
lines overwrite the previous lines. (This setting has no influence on what is saved in file!) 
If the number is set to ’0’ then lines/screen equals the height of the screen. 

Save:Enable if the picture to record has to be saved. 
Kepler load:Enable if Kepler data has to be loaded automatically after recording. See preferences
for Kepler file name and location. 
Start:Start record. Make sure that the Save button is in the right state! 
Stop:Abort record. Results up to now are kept. 
Exit:Exit this window. 



 

HRI

Record mode: Choose decoder or generator. (Not present if deocder type is switched instead of
decoder/generator; see preferences.) 
Record all: If set, all pictures are recorded (including encrypted pictures) 
Save: Click if the picture to record has to be saved. 
Start: Start record. Make sure that the Save button is in the right state! 
Stop: Abort record. Results up to now are kept. 
Exit: Exit this window. 



 

Raw

Records raw data from parallel port. Not for a specific format.
Bytes from parallel port are dumped in a file, without headers, frame separations etc. 

This option is ment for MSG, but can also be used to put raw HRI or HRPT data on disk. With HRPT
just the 8 MSB’s are recorded (2 LSB’s are lost), and channel selection has to be done using the HRPT
recording window or with switches on the hardware. (If there is a need to record all 10 bits in raw
format let me know.) 

The picture on screen during record shows 2048 pixels per line. HRPT and HRI are not shown correctly;
MSG recording will (should) show a vertical structure in 8 of the 2048 pixels per line. 

 

Menu: Channel.

Choose a channel to view.



 

Menu: Help.

Program info and test.

 

Program info

 

Test parallel port

If (C)HRPT is choosen: Select channel(s) using the HRPT Record window. 
Pre time: Determines how many pre-read cycles are done before data is actually catched. 

A small number will catch data nearly immediately; because decoder-buffer is full, data
transfer will go fast (waves look like ’HF’). 
A big number (1000000) will first empty the decoder-buffer and then catch data. Data looks



mostly ’LF’; data speed is limited by actual ’satellite’ data speed. 
Click on ’1x Read’ to catch data from par. port. 
Zoom time: Zoom in/out 
Offset time: Shift waves. 
Cont. Read: Continuous data read, waves are refreshed all the time. 
To stop: Click 1again on ’Cont. Read’, or click on ’1x Read’. (Note: If ’pre-time’ has a very high
number, and if data is read a long time, then it can take some time before reading is stopped. Click
on ’1x Read’ and wait. 

This image shows the result of waveforms with HRPT generator, channel 1 selected. This channel is a
black-to-white image; data is: 

0000000000
0000000001
0000000010
0000000011
0000000100
0000000101
0000000110
0000000111
0000001000
...
1111111110
1111111111

So, the LSB has a high frequency (pin 13), the MSB has the lowest frequency (upper ’data’ wave) which
is clearly shown in the picture. 

The Frame pulses mark the start of a new frame. 
’Sync’ is high (generator is always "in-sync") 
Readyn: This wave is not very reliably shown; it should be a pulse at every new word coming in.
A bigger value for ’Pre time’ and zooming in 100x or so will give a more realistic waveform for
this signal. 




