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Introduzione.
xrit2pic è un programma per trattare dati HRIT/LRIT/AVHRR , trasmessi da Eumetsat via satellite e internet. I formati supportati includono: 

· HRIT e LRIT, usati dai nuovi Meteosat Second Generation (MSG, come Meteosat-8, 9, etc.). 

· Dati di vecchi satellite come Meteosat 7 e precedenti, GOES e MTSATR, formattati come LRIT 

· LRIT si satelliti geostazionari americani 

· AVHRR di satelliti polari: 

· NOAA (formaformattato come bzipped HRPT) 

· METOP (formattato come EPS) 

· DWDSAT: supporto limitato 

I dati delle immagini possono essere visualizzati immediatamente, o convertiti in formati standard. 
Xrit2pic può effettuare alcuni semplici processi delle immagini; es. immagini in falsi colori possono essere ottenute sommando vari canali in differenti colori. Alcune mappature dedicate (es. per rilevazione di nebbia e polvere) sono già preinserite.
Xrit2pic può anche generare anaglifi (immagini 3D); la luminanza viene convertita come altitudine. 
E’ implementata la generazione di filmati, ed è possibile in combinazione con tutte le funzioni elencate. 
Per i satelliti polari l’orbita può essere tracciata su una mappa mondiale; è supportata la possibilità di selezionare parte dell’orbita per essere visualizzata od esportata. 
Qualsiasi processo viene fatto utilizzando direttamente i file RAW ricevuti, senza generare dei file intermedi. 

La figura mostra lo schema a blocchi di xrit2pic per la ricezione dei dati MSG.
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  Il sintonizzatore skystar2 tuner è un sintonizzatore standard per TV satellitare (una scheda PCI per computer od un sintonizzatore esterno via USB) 

  Il software Tellique estrae I dati dal sintonizzatore e li sistema sull’hard disk. Questo programma è disponibile presso l’Eumetsat. Notate che per ricevere tutti i dati è necessaria una chiave (USB); senza questa chiave l’accesso ai dati è molto limitato. Per maggiori informazioni vedere:
http://www.eumetsat.de/ 

  mencoder è un generatore di filmati esterno. E’ opzionale; xrit2pic adesso può generare filmati autonomamente (in formato AVI). 

Nota: Questo è un esempio; I dati provenienti dal servizio ftp Eumetsat, inseriti in un CDROM etc. sono egualmente trattati da xrit2pic. 

xrit2pic è disponibile per Linux e Windows. E’ anche compilabile per alter piattaforme (Sun/Solaris, MAC, etc.); è disponibile il codice sorgente. Notare che (per quanto ne so) in Eumetsat supportano solo Linux e Windows, per il loro software Tellique. 

Normalmente xrit2pic non necessita di PC con molta memoria: 

· Interfaccia grafica (GUI): 12Mb 

· Una finestra di anteprima di un immagine HRIT: 40Mb 

· Una finestra di anteprima di un imagine composta usando 3 canali: 90Mb 

Se vengono utilizzati canali HRV, necessita di maggiore memoria: 

· Una finestra di anteprima di un canale HRV: 105Mb 

· Visualizzare un immagine ad alta risoluzione composta usando 4 canali: 210Mb 

· Stessa cosa, ma tenendo l’immagine composta in memoria per un zoommata veloce, etc: 722Mb 

Nell’ultimo caso è necessario avere almeno 512Mb di memoria.

Per il METOP possono essere necessarie maggiori risorse. I dati di questo satellite polare possono essere virtualmente senza fine; un set di dati comprende orbite multiple. Mostrare un’orbita completa con 512Mb di RAM è possibile, se nessun altro programma sta girando. 

Io faccio funzionare una complete stazione ricevente MSG usando Linux su un PC a 2.4GHz contenente 512Mb di memoria. Questo è sufficente per ricevere immagini, visualizzare in automatic le immagini ricevute e cercare e visualizzare le immagini salvate precedentemente, allo stesso tempo, senza perdere dati in arrivo. (questo, senza visualizzare dati METOP!) 
L’esecuzione parallela di xrit2pic non è un problema. Notare, comunque, che xrit2pic può cancellare (su richiesta, certo) o spostare file; se una seconda istanza di xrit2pic sta usando gli stessi dati si può generare "confusione". 



Formati supportati.
Sono supportati i seguenti formati: 

· HRIT 

· LRIT 

· 10 bits per pixel piano 

· 8 bits per pixel piano 

· HRPT formato NOAA 

· EPS formato METOP 

· Messaggi di amministrazione (text) 

· JPEG provenienti da  MSG Data Manager di David Taylor 

· DWDSAT: 

· Attualmente solo gestione dei file

· Anteprima tramite un visualizzatore esterno

· Esportazione copiando i dati in una directory di destinazione



Settaggi.
xrit2pic ha settaggi di default per ogni cosa. Possono venire cambiati nella parte Preferenze; i settaggi dell’utente vengono salvati in xrit2pic.ini nella directory da dove il programma viene lanciato.

In aggiunta, lo stato della finestra principale dell’interfaccia grafica e di alcuni popup può venire salvato. All’avvio lo stato di tutti i bottoni e delle scelte in questa finestra viene ripristinato. Lo stato della GUI viene salvato in xrit2pic.gini. 

Ci sono 3 posti dove xrit2pic.ini e xrit2pic.gini vengono cercati dopo l’avvio di xrit2pic: 

· La directory da dove xrit2pic si avvia. 

· Nella directory $HOME (Windows: C:\). 

· Nella stessa locazione dove il programma viene installato.

Il primo file xrit2pic.ini/xrit2pic.gini che viene trovato è quello utilizzato. 

I 2 settaggi più importanti sono: 

· Sorgente: posto dove Tellique salva i file; per default: 

· Linux: da msg/received 

· Windows: c:\Programmi\T-Systems\Business TV-IP\received\ 

· Destinatione: posto dove le immagini convertite sono salvate; per default: 

· Linux: la locazione da dove il programma viene avviato. 

· Windows: C:\ 

I file sono in formato ASCII, e possono venire cambiati utilizzando un editor di testi, se lo si desidera. Per maggiori informazioni sui settaggi vedi il capitolo Settaggio directory e Preferenze. 



Xrit2pic e MSG Data Manager.
Usando xrit2pic assieme a MSG Data Manager di David Taylor possono insorgere problemi. Entrambi i programmi spostano e/o eliminano  i dati ricevuti, causando "interferenze": 

· xrit2pic sposta I dati ricevuti in ricevuto/completato, nel modo registrazione 

· MDM cancella I dati RAW dopo la conversione, o sposta i dati RAW in particolari directory 

Il risultato è che I due programmi possono mostrare perdita di segmenti.
Ci sono alcuni metodi per utilizzare assieme i due programmi, ma si consiglia: 

· Non usare xrit2pic e MDM assieme sulla stessa directory 'received'. 

C’è un eccezione: Puoi usare MDM per MSG e xrit2pic per AVHRR assieme, se non hai AVHRR Manager di David. xrit2pic ha uno special modo AVHRR, che lo  'nasconde' per i dati MSG; MDM viene 'nascosto' per AVHRR allo stesso modo. Così, MDM non toccherà I file AVHRR; xrit2pic non toccherà altro che non sia un file AVHRR. Questo previene conflitti fra I due programmi.
Notate che se xrit2pic è nel modo di aggiornamento continuo (vedi registra) e in modo AVHRR mode allora MDM dovrà essere attivato. Altrimenti la directory 'received' risulterà piena di file, e xrit2pic richiederà molto tempo per analizzare questa directory, per vedere se sono arrivati nuovi file. (Questa è una delle ragioni perchè insieme I due programmi mantengono vuota la directory received!) 



Finestra principale.
La figura 1 da un impressione del programma durante il suo utilizzo. 
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Descrizione della finestra principale:

· La linea blu mostra le ‘sessioni’ disponibili, es. immagini ricevute di una particolare ora e tipo (LRIT or HRIT). 

· Il codice nella colonna 'Formato' mostra brevemente il canale disponibile; V=Visibile,I=Infrarosso, W=Vapore acqueo 

· Aprendo una voce mostrerà tutti i canali ricevuti di quella sessione. 
Un canale 'completo', es. con tutti i segmenti disponibili, è colorato in verde. 
Un canale di cui si sono persi uno o più segmenti, è colorato in rosso. 

· La colonna 'Formato' ora mostra il metodo di compression utilizzato per l’immagine ricevuta (Wavelet, JPEG) 

· La colonna 'Segmenti' mostra il numero di pezzi (file) per ogni canale: valore attuale e quelli in attesa. Normalmente questi due numeri sono uguali. 


per la corretta vision del canale HRV serve il file di prologo. Se manca questo file la linea HRV è colorata in giallo. 

· Se lo si desidera la voce di un canale può essere aperta; questo mostrerà tutti i segmenti di quel canale. 

· La colonna 'Formato' mostra la grandezza di ogni segmento. 

· La colonna 'Segmenti' mostra il numero di segmento. 

· La colonna 'Canale' mostra una stima approssimata della gamma di latitudine di ogni segmento. 

La selezione può essere fatta in diversi modi: 

· Selezionando un set di canali cliccando sulla linea blu. 

· Selezionando un canale cliccando su una linea verde (o rossa). 

· Selezionando un segment di canale, cliccando su una linea nera. 

Sono possibili selezioni multiple, per set, canali o segmenti: 

· Cliccare sul primo element da selezionare, mantenere premuto il pulsante del mouse e spostare il mouse fino all’ultimo elemento da selezionare, rilasciare il pulsante. 

· oppure: Cliccare sul primo element da selezionare, spostarsi sull’ultimo element desiderato, premere il tasto shift e cliccare sull’elemento. Tutti gli elementi fra le due selezioni verranno attivati. 

· Per aggiungere un singolo elemento alla selezione: Premere il tasto control e cliccare sull’elemento da aggiungere. 

Pulsanti nella finestra principale.

Per facilitare la selezione alcuni elementi visibili possono venire nascosti, usando il second bottone sotto 'Lista' (ora mostra 'Tutto'); es. solo le immagini HRIT possono essere rese visibili, o solo LRIT MET7, etc. 
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Apri: Espande la lista di un livello, così tutti i canali saranno visibili. Cliccando ancora si chiuderà la lista. 

Voci del menu

· File -> Nuovo: Pulisce la lista e legge nuovamente il contenuto della directory di ricezione. (Vedi anche 'Aggiorna 1x' in the regis. part.) 

· File -> Dati RAW: Genera uno script contenete gli elementi selezionati. Avviando questo script farà una 'ls' ('dir') per tutti gli elementi. Sostituendo il comando ls (dir) nello script 'qualsiasi cosa' potrà essere fatta con gli elementi selezionati (es. spostarli in un altra directory). 

· File -> File selezion.: Mostra I file collegati all’elemento (i) selezionato (i) 

· File -> Info file selez.: Mostra informazioni dettagliate (contenuto dell’intestazione) dell’elemento (i) selezionato (i) 

· File -> Archivio selez.: Archivio degli elementi selezionati (una finestra popup permette di scegliere l’archivio di destinazione) 

· File -> Elimina: Elimina I vecchi elementi (vedi preferenze).

· File -> Elimina selez.: Elimina gli elementi selezionati dalla lista.
Nota: L’eliminazione di file AVHRR è possible solo dopo aver selezionato una linea blu. Un singolo canale non può essere eliminato poiché tutti i canali sono in un file. 

· File -> Elimina film temp.: Questo è necessario specialmente se i filmati vengono create automaticamente utilizzando i dati ricevuti. I filmati vengono creati da separate file Jpeg sistemati in una speciale directory. Cominciando da zero questa directory sarà vuota. Vedi Generazione di filmati. 

· File -> Mostra file bordi: Mostra tutti I file disponibili per i contorni dei continenti e degli stati (vedi Bordi.) 



· Edit -> Preferenze: See Preferenze 

· Edit -> Salva GUI: Salva lo stato di pulsanti,ecc..; questi settaggi saranno ricaricati dopo il riavvio.  



· Proiezioni -> AVHRR lin: Linearizza le immagini AVHRR 

· Proiezioni -> Proj -> : Usa delle mappe speciali: 

· Plate Carree 

· Mercator 

· Polar north 

· Polar south 



· View -> lon_lat: aggiunge le line di latitudine e longitudine alle immagini 

· View -> Esport.: Dopo la pressione, l’esportazione e la generazione del file sono completate un visualizzatore mostrerà l’immagine esportata. Vedi Preferenze. 

· View -> Anagl.3D: Per visualizzare/esportare immagini in 3D. per vedere l’effetto 3D servono un paio di occhiali con lenti colorate blu/rosso. 

· View -> Temp_IR: Mappa immagini IR sopra una mappa colorata second la temperatura (rosso=caldo, blu=freddo) 

· View -> Incen: Rilevazione incendi. 



· Area: Scelta dell’area per I satellite geostazionari. Le scelte (nomi ed area) dipendono da quanto è definito in Preferenze (Genera part). Default: 

· Europa: Solamente immagini con parti dell’Europa saranno visualizzate/esportate (grandezza = 1/4x1/4 dell’originale). 



Dopo avere selezionato uno o più elementi si potrà avere l’anteprima del file o la sua conversione. 



Azioni di base.


Anteprima.
· Selezionare l’immagine da visualizzare. 

· Cliccare su 'Vedi'. L’immagine selezionata (od il messaggio) sarà ora visibile. 

· Per ingrandire, premi 'i' 

· Per ingrandire un particolare posiziona il cursore e premi 'I'. 

· Per rimpicciolire, premi 'o' 

· Ingrandimento massimo: premi 'f' o 'F' 

· Spostamenti sull’immagine possono essere fatti con i tasti freccia oppure utilizzando le scroll bar. 

Nota: Nella parte superior della finestra vengono mostrate le seguenti indicazioni: 

· Z=[x,y]: fattore di ingrandimento 

· N=[x,y]: gamma di pixel visibili 

· D=[x,y]: pixel dell’immagine per pixel dello schermo. Un valore di un mezzo: un pixel dell’immagine viene mappato esattamente su un pixel dello schermo. 

· Elementi di menu: 

· Vedi -> Lumgraph: Popup con grafici RGB e luminanza. 

· Vedi -> Zoom: 

· ->Values: Aggiunge pulsanti per la regolazione fine dell’ingrandimento 

· ->Full:Ingrandimento massimo (tasto: 'f') 

· ->Full: Ingrandimento (tasto: 'i') 

· ->Full: Rimpicciolimento (tasto: 'o') 

· Vedi -> Redraw : Ridisegna l’immagine 

· Vedi -> Flip : Nel caso di immagini rovesciate; normalmente non necessario 

· Vedi -> Invert : per invertire la luminanza, es. per immagini IR 

· Vedi -> Projection: Cambia proiezione 

· Plate Carree, Mercator, Polar north, Polar south 

· Vedi -> Overlay : Abilita i contorni 

· Vedi -> Lon-lat : Aggiunge le linee di latitudine e longitudine 

· Vedi -> Temperature : Abilita la mappatura di temperature per i canali IR 

· Vedi -> Scatterometer : Pop-up per aggiungere i risultati dello scatterometro all’immagine 

· Vedi -> Pixel quadrati : x/y in proporzione, es., la terra è mostrata come un cerchio, indipendentemente dalla grandezza della finestra. 

· Vedi -> Fast : Elabora l’immagine mantenendola in memoria. Questo rende ingrandimenti e spostamenti molto veloci (ma viene utilizzata più memoria). 

· Vedi -> Show (x,y) coord : aggiunge pulsanti per mostrare i pixel x,y del cursore 



· File -> Save jpeg : salva l’immagine (ingrandita o rimpicciolita) in formato jpeg. 

· File -> Save pgm : salva l’immagine (ingrandita o rimpicciolita) in formato pgm. 

· File -> Save pgm8 : salva l’immagine (ingrandita o rimpicciolita) in formato 8bbpp pgm, anche se il sorgente è a 10 bpp. 

· File -> Screendump: salva la schermata di un immagine in formato 8 bbpp pgm. 



· Lum : calcola la mappatura ottimale della luminanza. 

· Hue : regola RGB allo stesso livello. 

· Lmin, Lmax: Regola manualmente la luminosità. Cambiata anche tramite Autolum. 

· Frz clr : Per immagini composte; blocca la mappatura dei colori. 

· More : Apre ulteriori regolazioni etc.: 

· Ovl_dim: Riduce la luminosità delle linee di confine. 

· Pos: Questo campo mostra la posizione del cursore (AVHRR, se il file Kepler è disponibile: mostra longitudine/latitudine) 

· Val: Valore del pixel (se si trova in mappatura di temperatura, per i canali IR: mostra la temperatura nella posizione del cursore in gradi Celsius) 

· Gamma: Regola la correzione di gamma. 

· Sono visibili pulsanti extra, se viene selezionato Anaglyph: (vedi Anaglyph per maggiori dettagli). 

· Shift: La massima percentuale di scostamento (in pixels) tra rosso (sinistra) e blu (destra). 

· Lbnd, Hbnd: basso/alto livello; differenze di profondità vengono mostrate fra questi due livelli. 

· Init: Spunta questo per regolare i livelli di Lnbd e Hbnd in maniera semplice. 

· Dpthchan: Canale utilizzato per le informazioni di profondità.
Se non è selezionato viene utilizzata la luminanza dell’immagine.
Se viene selezionato un canale apposito (vedi Preferences) sarà quello utilizzato. Per default questo è il canale 9 (IR_108). 

· OL_3D: se viene selezionato l’overlay (vedi la finestra principale quando il confine (overlay) viene visualizzato come livello di profondità.
Se non viene selezionato i confini vengono visualizzati come una solida linea bianca, come in un sistema bidimensionale. 

· OL_lum: Luminosità dei confini 3D. 

Nota: 

· I settaggi di Preview –anteprima- (ingrandimento, inversione, rotazione, regolazioni di luminanza, etc.) vengono effettuati tenendo conto che l’immagine sia salvata usando la voce di menu  'File -> Save' della finestra preview. 

· 'Save pgm': Il format esatto dipende dall’immagine da salvare: 

· Colori danno formato PPM 

· HRIT da PGM 16 bits per pixel 

· LRIT da PGM 8 bits per pixel 

Nota:
Disegnare un imagine per la prima volta richiede un pò di tempo poiché i dati debbono venire decompressi. (Per un imagine a colori ad alta risoluzione dovranno essere decompresse 4 immagini). Per velocizzare il ridisegno: 

· Assicurarsi che 'Memory usage: Minimize' sia Off! (vedi preferenze 'Misc'). I dati verranno tenuti in memoria finchè la finestra di preview resta aperta. 

· Se hai abbastanza memoria (almeno 512Mb): Seleziona 'View -> Fast'. Questo velocizza specialmente le immagini composte (colori, colori alta risoluzione).     (I dati dopo la composizione restano in memoria.) 

· Interessati all’Europa: Spunta 'Europa' nella barra menu della finestra principale. 

· Durante la conversione ed il disegno, se vuoi ingrandire: non aspettare che la figura sia disegnata. Solo i segmenti visibili vengono convertiti; non c’è il bisogno di attendere l’immagine completa prima di ingrandire un particolare. (L’ingrandimento non ha un effetto immediato; deve essere prima completata la conversion del segmento.) 

Esporta
· Selezionare l’immagine (o il messaggio) da esportare (es., genera un file). 

· Seleziona 'Compose' per generare un imagine a colori (per questo gruppo, es. una linea blu, è stata selezionata). 

· Scegli Europa e/o Anaglyph se lo desideri. 

· Clicca su Esport.. 

Il format di default dell’immagine da esportare dipende dal format nel quale è stata ricevuta: 

· PGM16 per immagini trasmesse in formato Wavelet 10 ormat (es. HRIT) 

· PGM8 per immagini trasmesse in formato Wavelet 8 (es. LRIT estero) 

· PPM per immagini a colori trasmesse in formato Wavelet 8 (es. LRIT estero) 

· JPEG per immagini trasmesse in format JPEG (LRIT MSG) 

· Per AVHRR: 

· RAH se un gruppo (linea blu) viene selezionato e la finestra mapping colori non è aperta (solo NOAA!) 

· PPM se un gruppo (linea blu) viene selezionato e la finestra mapping colori è aperta 

· PGM16 se un canale (linea verde) viene selezionato 

Nota: RAH è un formato hrpt 10-bits-per-pixel. Questo viene letto da: 

· wsat (vedi per formato 10Bformat) 

· HRPTReader (di David Taylor) 

Vedi Altre funzioni per la scelta di formati differenti. 

Se l’immagine dovrà essere esportata con opzioni speciali, es. ingrandita, regolazioni personali di luminosità, etc., usa il menu File->Save nella finestra di preview. 



Trattamento dei dati.
Contenuto: 

· Confini 

· Composizione (immagini colorate) 

· Mappature speciali

· Immagini a colori ad alta risoluzione 

· Quando qualcosa viene generato. 

· Anaglifi



Confini for MSG: Confini di città, etc.
Ci sono due modi per aggiungere linee di confine degli stati e i contorni delle coste: 

1. Utilizzare le “immagini” di overlay di Eumetsat 

2. Utilizzare file vettoriali di overlay

Il tipo preferito può essere scelto da Preferenze, linguetta 'genera'. Il tipo preferito verrà processato prima dell’altro tipo. 
Tutti e due I tipi di file potranno essere scaricati. 

File immagini di overlay.

Scarica I file di overlay:
http://oiswww.eumetsat.org/WEBOPS/coastlines/2008-05-14 
Quì puoi scegliere se scaricare ogni file di overlay singolarmente (scegli "singleFiles") o scaricare il file zippato (scegli "zipped") Nella cartella compressa puoi trovare zip-file per msg, esteri (fsd) o met prima generazione (mtp), scaricando ogni cosa in un solo file compresso. 
Non cambiare il nome dei file. Sistemali in una delle seguenti posizioni: 

· Nella stessa directory dove è installato il programma

· Nella directory da dove xrit2pic viene avviato (da preferire) 

· Nella directory $HOME (Windows: C:\) 

xrit2pic utilizza lo stesso algoritmo di ricerca utilizzato per il file xrit2pic.ini.
Seleziona 'Bordi' e scegli il tipo di contorno desiderato (default: paesi). 
Nota: xrit2pic determina quale overlay utilizzare con le seguenti informazioni: 

· Satellite: MSG (meteosat 8,9), meteosat 7/6/5, goes o mtsat 

· Canale mostrato

· Tipo di overlay scelto (coste, paesi) 

· Una tabella interna collega il file contenente l’overlay (ecco perchè non deve assolutamente essere cambiato il nome ai file) 

File vettoriali di overlay.

Scarica il file:
gshhs_i.b 
Non cambiare il nome del file. Copialo in una delle seguenti directory: 

· Nella stessa directory dove è installato il programma

· Nella directory da dove xrit2pic viene avviato (da preferire) 

· Nella directory $HOME (Windows: C:\) 

Questo file di overlay è disponibile per tutti I satelliti, inclusi quelli polari se vengono visualizzati con una speciale proiezione (plate carree, plar etc.). per i NOAA è necessario un file Kepler (vedi sotto). METOP non necessita del file Kepler poichè I dati orbital sono inclusi nei file ricevuti. Attualmente sono disponibili solo le linee costiere. (Nota: Per alcune ragioni l’Australia è nascosta...) 

Linee lat/lon.
Linee di latitudine e longitudine possono essere attivate per ogni satellite; vedi menu Vedi->lon_lat. Per i NOAA è necessario un file Kepler disponibile ad es.: http://www.celestrak.com/NORAD/elements/noaa.txt 
Il file può contenere voci multiple per ogni satellite; xrit2pic prenderà la più recente. Nota: Il file non dovrebbe essere troppo vecchio, per aumentare la precisione. Per cui questo file dovrà essere sostituito di tanto in tanto. 
Il nome del file noaa (default 'noaa.txt') può essere cambiato nelle preferenze. 

Immagini a colori.
La generazione di immagini a colori è possible con 'Preview' o come file in formato 3-bytes PPM o JPEG. 

Se viene selezionata una ‘linea blu’ allora può essere generata un’immagine a colori; Clicca su 'Attiva' nel riquadro 'Colori'. Per default viene usata la seguente mappatura: 

	
	red 
	green 
	blue 

	HRIT 
	IR016 
	VIS008 
	VIS006 

	LRIT 
	IR016 
	-- 
	VIS006 

	AVHRR 
	Ch1 
	Ch2 
	Ch4 

	
	
	
	


Queste scelte di default sono sovrascritte con le seguenti opzioni da linea di comando -r, -g, -b, -ro, -go e -bo. Vedi Modo linea di comando. 

Selezionando il bottone 'Mappat.' Appare una finestra popup dove puoi cambiare la mappatura: 
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Il contributo di ogni canale su qualsiasi colore poò essere cambiato utilizzando i bottoni a scorrimento presenti in basso, tra (es.) +100 e  -100%. 
Per ogni colore può essere definite una compensazione. 
Il calcolo del contributo di ogni canale dipende dalla spunta della casella 'Mirror neg. values'. 

· Se spuntata: 

· valore=ABS(val_chan1*fact1 + val_chan2*fact2 + ...)

· Se non spuntata: 

· valore=offset + val_chan1*fact1 + val_chan2*fact2 + ...
Un valore negative verrà cambiato a 0.

Con una compensazione diversa da 0 è possible invertire il contributo di un canale: settando la compensazione a 100 ed il contributo a -100.
(Nota che all’inizio non è necessario definire una compensazione separate per ogni canale; le compensazioni di tutti i canali vengono semplicemente sommate.) 

Alcune mappature di default sono già inserite nel programma: 

· colori normali

· rivelazione nebbia notturna (nebb-nott)

· rivelazione nebbia giornaliera(nebb-gi)

· rivelazione polvere (polv)

· airmass (airm)

· Diverse mappature microfisiche

Queste vengono selezionate usando il pulsante sotto a destra, con la scritta "nrgb" (normal RGB, che è di default). 

Finestra mappature speciali.

Le speciali mappature menzionate, come airmass, nebbia, ecc., usano un canale o una differenza di due canali per ogni colore. Xrit2pic ha una finestra speciale per modificare le mappature. I margini di temperatura possono essere digitati direttamente. Se viene selezionata una mappatura particolare I valori saranno visibili in questa finestra,  e possono venire regolati facilmente, se necessario. 
Vedi la figura sotto: Ogni colore può avere al massimo due canali associati. Quello a destra (nella colonna "Chan N") sarà sottratto da quello di sinistra ("Chan P"). 
Le due colonne seguenti (Temp L, Temp H) danno i margini di temperatura tra i quali vengono mappati i canali. 
Es.: Nella figura sotto il canale IR_108 è sottratto da IR_120. Una differenza di -4 Kelvin ed inferior sarà mappata su "Black", una differenza di +2 Kelvin o maggiore su "Red". Tra -4K e +2K la mappatura dipende dalla variazione di gamma; gamma=1 da una mappatura lineare. 

Dopo le modifiche cliccare su "Set" per renderle effettive. 
Se un canale non è disponibile il pulsante sarà colorato di rosso. 
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Immagini a colori ad alta risoluzione.
Immagini a colori ad alta risoluzione sono possibili utilizzando il canale HRV per la luminanza e altri canali per la crominanza. 
Attiva 'Colori' ed 'Hires'. Vedi capitolo precedente per selezionare altri canali oltre a quelli di default per la mappatura dei colori. Non utilizzare HRV per uno dei colori. 
Nota: Per una perfetta mappatura di HRV sopra altri canali è necessario che sia presente il file di prologo (vedi PRO_EPI nella lista). In questo file sono definite le posizioni esatte dei particolari superiori ed inferiori. Se questo file non è presente verranno utilizzati dei valori di default per lo spostamento dei particolari superiori. (Questi valori sono diversi per ogni immagine, per questo è importante avere disponibile il file di prologo.) 

Cosa verrà generato.
Se un gruppo (linea blu) viene selezionato ci sono diverse possibilità di cosa succeda dopo aver cliccato su Vedi o Esporta: 

· Colori ed Hires non selezionati.
Selezionando un gruppo: selezionando tutti i canali, come parti separate. Cliccando Vedi o Esporta uscirà una finestra popup dove potrai selezionare i canali da processare. Risultato: un’immagine per ogni canale. 

· Colori selezionato, Hires no.
Verrà generate un immagine, utilizzando i canali del gruppo, ed una mappatura stabilendo quale canale (i) sulla mappa con quale colore(i). Mappature di default sono inserite nel programma, selezionabili tramite un pulsante per nrgb, nebbia, polvere ed airmass. Le mappature possono essere cambiate aprendo la finestra delle mappature colori.
Nota: Anche il canale HRV può venire utilizzato. 

· Colori ed Hires selezionati.
Stessa applicazione, ma ora i canali a bassa risoluzione vengono usati per definire la crominanza; la luminanza viene tolta. Instead, il canale HRV viene usato per definire la luminanza.
Il canale HRV non copre tutto il disco terrestre, attualmente, copre una forma ad 'L'. Xrit2pic creerà un imagine rettangolare in modo che tutti i particolari dell’HRV siano presenti. Dove non è presente l’immagine HRV, verranno utilizzati i canali a bassa risoluzione, es. come se Hires non fosse selezionato. 

Se vengono selezionati gruppi multipli, ed i colori sono attivi, si attiverà la finestra popup. Questo è utile specialmente in fase di esportazione; nella popup puoi definire se e come generare un filmato. La finestra mostrerà anche il progresso del processo di generazione. 

Anaglifi.
See Dettagli sulla generazione di anaglifi 



Mappature geografiche.

Attualmente è implementata una special mappatura: Plane Carree (una specie).
Nota: Questa mappatura non è esattamente Plane Carree; guarda le line di lon/lat con attivato overlay (confini)! 



Conversione di immagini multiple.


Generazione di immagini multiple.
Se viene selezionato immagini multiple allora, dopo aver cliccato su 'Vedi' o 'Esporta' apparirà una finestra con tutte le immagini selezionate. 
(Nota: se una linea 'blu' viene selezionata, ma 'colori' non è attivo, allora tutti i canali sotto questa linea vengono selezionati come immagini separate. Così uscirà la finestra suindicata.) 

· Selezionare quale canale(i) sarà convertito. Es. se viene selezionato il gruppo 10 HRIT è possibile generare immagini per VIS006 e VIS008. Il risultato saranno 20 immagini. 

· Selezionare il format di salvataggio (pgm, jpeg, default). 

· Se debbono essere generate delle immagini ingrandite: 

· Clicca su 'Preview' nella finestra popup (NON nella finestra principale). Apparirà una finestra speciale di anteprima con la prima immagine selezionata. 

· Ingrandisci e cambia le regolazioni di luminosità, se lo desideri. 

· Clicca su  'Do it'. 

· Clicca su 'Abort' per fermare tutte le conversioni. (La conversione corrente verrà completata.) 
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Premendo 'Help' avrai una visione del significato dei 'led di stato': 
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Generazione di filmati.
I filmati vengono generate in format AVI. E’ possible utilizzare un convertitore contenuto nel programma oppure un 'mencoder' esterno, che avrai installato precedentemente. 

· Nella finestra principale: assicurati che un imagine sia mostrata nella lista, es. "Hrit". (sezione 'Lista', in basso). 

· Clicca su 'Select all' o scegli manualmente le immagini da includere nel filmato. 

· Clicca su 'Esporta'. Apparirà una lista di conversione. 

· Selezionare in questa nuova finestra un canale da utilizzare per il filmato. 

· Seleziona 'Movie'. 

· Seleziona 'Time id' se vuoi informazioni di data/ora per ogni fotogramma (nell’angolo sinistro superiore). 

· Se deve essere generato un filmato ingrandito: 

· Clicca su 'Preview' nella finestra popup (NON nella finestra principale). Apparirà una speciale finestra di anteprima con la prima imagine selezionata. 

· Ingrandisci e cambia le regolazioni di luminosità, se lo vuoi. 

· Clicca su  'Do it' per far partire la generazione del filmato. 

Ora tutte le immagini selezionate verranno convertite in JPEG, in una speciale directory. Dopo il completamento della conversione verranno combinate in un filmato formato AVI. 

Nota sull’utilizzo della finestra di anteprima: La prima immagine selezionata verrà mostrata nella finestra di anteprima. Se questa imagine non è disponibile per le regolazioni allora settings: 

  Selezionare l’immagine dad over regolare. 

  Clicca su  'Preview'. 

  Selezionare ora tutti gli elementi da utilizzare per il filmato. 

Alcune funzioni extra per i filmati: 

· Per generare filmati a colori attiva 'Colori' (se lo desideri puoi cambiare la mappatura dei colori). 

· Per utilizzare una percentuale limitata di segmenti riempi il campo 'Segmenti' nella finestra di conversione.' 
Es. digita 8 o 6-8 per utilizzare questi segmenti. 

· Per saltare fotogrammi incompleti attiva il pulsante 'Skip incomplete'. 

· Se vuoi puoi cambiare la dimensione massima. Quella di default, 2048x2048, può essere cambiata nelle preferenze. Ad esempio se viene generato un filmato HRIT (dimensione 3712x3712) la dimensione potrà venire cambiata in 1856x1856 (3712/2). (Nota che alcuni riproduttori di filmati, es. mplayer, non possono lavorare con una dimensione maggiore di 2048x2048.) 

La generazione di un filmato di un paio di giorni richiederà molto tempo, specialmente la generazione di tutti i file jpeg (96 per un filmato di un giorno) è molto intensiva per la CPU.
Normalmente, dopo che è stato generato il file AVI, questi file vengono eliminati. Comunque, puoi scegliere se tenere questi file per poterli riusare. Se ad esempio altri fotogrammi verranno aggiunti al filmato, solo questi dovranno essere convertiti. 

Nella finestra Translate, nella seconda riga di pulsanti, scegli 'Tempfiles': 

· Reuse: solo se ti serve generare il filmato; non cancella i file temporanei 

· Replace: rigenera I file temporanei, ma non li cancella 

· Remove: cancella tutti i file temporanei utilizzati dopo la generazione del filmato. (I file non utilizzati nel filmato non vengono rimossi.) 

Prima di riusare un file xri2pic controller se la dimensione è corretta. Se non lo è, rigenera il file. 

Generazione di immagini o filmati ingranditi o regolati.
Dopo aver premuto 'Preview' nella finestra popup (NON in quella principale!) apparirà una finestra di anteprima. Tutte le regolazioni fatte in questa finestra vengono utilizzate per la generazione di immagini o filmati. 

Se vengono selezionati elementi multipli solo il primo element verrà mostrato in anteprima. E’ comunque possibile utilizzare un altro elemento per fare le regolazioni: 

· Selezionare l’elemento che vuoi utilizzare per le regolazioni. Es. se vuoi generare un filmato per un giorno probabilmente vuoi usare l’immagine di mezzogiorno per la regolazione di luminosità. 

· Clicca su 'Preview'. Dopo potrai selezionare l’attuale set di elementi. 

· Fai le regolazioni nella finestra di anteprima (ingrandimento/spazzolata, regolazioni di luminosità, regolazioni degli anaglifi se desiderato). 

· Scegli 'Movie' ed altre caratteristiche se lo desideri. 

· Clicca su 'Do it'. Adesso le regolazioni nella finestra di anteprima verranno usate per tutti gli elementi selezionati. 



Registrazione.
Xrit2pic può aggiornare la lista e mostrare le immagini così come vengono ricevute (es., scaricati dal software Tellicast nella directory Received).
Anche le immagini possono venire generate, ed I dati RAW venire eliminate automaticamente. 
Clicca sulla linguetta Regis. (Record). 
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  Per aggiornare l’elenco: 

· Per un aggiornamento clicca Aggiorna lista 1x (Update list 1x.)

· Per un aggiornamento continuo clicca su Inizia aggior. (Start updating.) La frequenza di aggiornamento è ogni 3 secondi (può essere cambiata nelle preferenze). 

Le prossime funzioni lavorano solo durante l’aggiornamento continuo. 

  RX diretta (Show 'live'): 

· Per vedere l’immagine appena dopo essere stata ricevuta clicca su Vedi (Show) 

· Scegli un satellite e digita un canale da visualizzare (se questo campo è vuoto, tutti i canali vengono disegnati uno sopra l’altro). 

· Per visualizzare immagini a colori spunta la casella 'Colore' (Colour). La mappatura di default, IR-016=rosso / VIS008=verde / VIS006=blu, può essere cambiata aprendo la finestra Map colore. 

  Generare immagini da dati RAW: 

· Spunta 'ok' (on) nel riquadro 'Genera' (Generate). I dati del canale scelto in RX diretta' verranno convertiti in un immagine con formato standard. 

· Spunta 'Film' (Movie) per creare filmati. 

· Spunta 'Id ora'  (Time id) se vuoi aggiungere informazioni su data/ora. 

  Eliminare dati RAW: 

· Spunta 'Elimina' (Delete) nel riquadro 'Dati RAW' (Raw  data) e scegli quail canali conservare. Tutti I dati che non riguardano i canali selezionati verranno eliminati immediatamente dopo che Tellicast ha scaricato i dati nella directory received.
Se, comunque, debbono essere generati dei file (vedi punto precedente) allora tutti i dati vengono conservati finchè non siano completi per la generazione del file. Dopodichè i file non selezionati verranno eliminati. 
Nota: Solamente i dati ricevuti (es., ricevuti dopo aver premuto 'Inizia aggior.') vengono eliminati. Vecchi dati nella directory received non vengono cancellati.

Per  MSG, i dati da eliminare possono essere specificati per ogni canale. 

· Spunta 'Tieni scon.' (Keep unknown) per conservare i file ricevuti non-xrit. Questi sono file compressi da es. NOAA. 



Gestione file.
Clicca sulla linguetta Archivi (Archive).
Clicca su Aggiorna (Update) per aggiornare la lista delle directory. (Normalmente è necessario solo una volta dopo l’avvio del programma.) 
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xrit2pic usa la seguente struttura di directory per lavorare con i dati xrit: 

· received: directory dove Tellicast scarica i dati ricevuti 

· done (completati): una directory di aiuto; normalmente gli utenti non hanno la necessità di conoscerla, ad eccezione se per qualsiasi ragione vuoi sistemare i file senza xrit2pic. 

· archive: contiene directory per ogni data, contenente i dati della data stessa. 

Spostare i dati tra received ed archive: 

· Sposta in arch. (Move to Archive): Sposta I dati dalla cartella received ad archive; I dati vengono suddivisi in sottodirectory per ogni data. 

· Sposta da archivi (Move from Archive): Sposta il contenuto della(e) directory indietro. (Generalmente questo non è necessario.) 

· Carica selez. (Load selected): Carica la(e) directory selezionata(e) nella lista. 

· Elimina selez. (Delete selected): Elimina il contenuto della(e) directory. 

Nota: Oltre a HRIT/LRIT ed AVHRR vengono trasmessi altri tipi di dati, es.: 

· amsub 

· hirs 

xrit2pic etichetta questi file come 'unknown'. Potranno essere spostati nella directory archive/unknown. 

Spostare dati fra le directory received e done:
Generalmente non necessario. 

· Sposta in comp (Move to done): 

· Sposta da compl. (Move from done): 



Gestione file esportati/generati.
Clicca sulla linguetta Esport. (Exported). 
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I file esportati/generati (inclusi I filmati) nella directory di destinazione sono adesso visibili. Possono venire visualizzati utilizzando un programma esterno an external viewer (vedi 'Viewer programs' nelle preferenze) o cancellati. I file temporanei, utilizzati per generare i filmati, sono accessibili attraverso questa finestra. 

<hr size=3 width="100%" align=center> 

File prologo/epilogo.
I file HRIT hanno un file di prologo ed epilogo per ogni gruppo di canali (di un certo periodo). Nella lista vengono mostrati immediatamente sotto ad un gruppo, allo stesso livello come i canali. 
I file GOES LRIT files hanno un file di prologo dedicato per ogni canale. Questi sono visualizzati allo stesso livello come i segmenti, un livello sotto ogni canale. 

Attualmente xrit2pic utilizza i file di prologo solamente per ottenere la posizione delle due parti del canale HRV. Il file di prologo utilizzato è visibile usando Preview (selezionare prima il file di prologo dalla lista). 
Se i dati vengono processati utilizzando programmi esterni possono essere necessari i dati di prologo/epilogo. Per questo scopo possono venire esportati. 
Per estrarre un file di prologo/epilogo file selezionare l’elemento e cliccare su 'Esporta' (Export). 

E’ possible esportarei file di prologo/epilogo in modo automatico assieme ai canali. vedi 'Altre funzioni'. 



Altre funzioni.
Premendo il bottone 'Altro' (More) (sotto a destra) diverranno visibili alcuni pulsanti usati meno frequentemente: 
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Bitselect.
Attivo solo se le immagini con più di 8 bits per pixel devono essere mappate ad 8 bits per pixel: 

· Generazione di PPM a colori (3x8 bits) da Wavelet a 10-bits. 

· Anteprima: Immagini con più di 8 bits per pixel. 

Scelte: 

· [9:2]: Gli 8 bit più significativi verranno utilizzati/salvati; i 2 LSB sono persi. 

· [8:1]: Il bit MSB verrà usato per accorciare, gli altri 8 bits verranno utilizzati/salvati, theil bit LSB verrà perso. 

· [7:0]: I 2  bit MSB saranno utilizzati per accorciare; gli 8 bit LSB verranno usati/salvati. 


Es.: Un pixel a 10-bit con valore 261=01 0000 0101: 

· [9:2] darà: 01000001 (LSB '01' persi) 

· [8:1] darà: 10000010 (LSB '1' e MSB '0' persi) 

· [7:0] darà: 11111111 (MSB '01' persi; accorciato il pixel al valore 255) 

Il 'cerchio' grigio sotto questa selezione mostra come la luminanza dell’immagine cambia per ogni selezione. 

Invert.
Inverte l’immagine. Per anteprima ed esportazione.
Nota: Nell’anteprima c’è un’altra opzione Inverti. Queste due funzioni si eliminano a vicenda, es., attive entrambe -> nessuna inversione. 

3D sh.
Attivo se Anaglyph è selezionato. Cambia il Massimo scostamento visione sinistra e destra (in pixel).

AVHRR Range settori
Seleziona un determinate pezzo di orbita da processare/visualizzare. Utile specialmente con passate molto lunghe del METOP.

· Iniz: segmento di partenza 

· Num: numero di segmenti (da 0 a tutti, con un massimo di 102 minuti di segmenti corrispondenti a circa un’orbita). 

Dopo aver premuto il pulsante 'World map' viene visualizzata una mappa mondiale con segnata l’orbita del satellite selezionato. La parte di orbita selezionata è colorata in rosso.
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  Choose (scelta): North pole, south pole, full 

  Direction (direzione): North nound, south bound 



Format.
Determina il formato del file generato. 

Per default verrà generato con la più alta qualità possibile: 

· Se l’origine è un Wavelet a 10-bit: verrà generato un PGM a 16 bit. 

· Se l’origine è un Wavelet ad 8-bit: verrà generato un PGM ad 8 bit. 

· Se l’origine è un JPEG ad 8-bit: verrà generato un JPEG, senza decompressione intermedia. 

Potranno essere generati i seguenti formati: 

	
	default 
	Selezionato PGM 
	Selezionato JPEG 
	Selezionata la linea blu 

	
	
	Bianco & nero 
	colore 
	Bianco & nero o colore 
	

	LRIT (Meteosat) 
	JPEG 8 bits (1) 
	PGM 1 byte 
	PPM 3 byte 
	JPEG 24 bit (2) 
	Seleziona finestra popup 

	LRIT (foreign) 
	PGM 1 or 2 byte 
	PGM 1 or 2 byte 
	(non supportato) 
	JPEG 24 bit 
	Seleziona finestra popup

	HRIT except HRV 
	PGM 2 byte 
	PGM 1 or 2 byte 
	PPM 3 byte 
	JPEG 24 bit 
	Seleziona finestra popup

	HRIT HRV 
	PGM 2 byte 
	PGM 1 or 2 byte 
	(non supportato) 
	JPEG 24 bit 
	

	AVHRR 
	PGM 2 byte 
	PGM 1 or 2 byte 
	PPM 3 byte 
	JPEG 24 bit 
	rah (fper wsat, hrptreader) 

	EPS 
	PGM 2 byte 
	PGM 1 or 2 byte 
	PPM 3 byte 
	JPEG 24 bit 
	rah (per wsat, hrptreader) 

	Admin 
	Formato testo (ASCII) 

	Altro
	Formato binario 


Note: 

· (1) Generato senza decompressione. Vantaggi: Nessuna perdita; svantaggi: imagine rovesciata (in molti casi). 

· (2) L’originale viene prima decompresso, vengono uniti i segmenti, e ricompresso. Svantaggi: Perdita; vantaggi: l’immagine può essere generata diritta. 

Note sui formati dei file.

· JPEG 12 bits, benchè sia un format standard, non è molto comune. (Attualmente questo formato non è trasmesso dall’ MSG.) 

· PGM 2 bytes sembra non essere ben definito; alcuni programmi utilizzano il formato chiamato Little Endian (LSB prima), altri Big Endian (MSB prima). L’ultimo sembra essere più comune, così xrit2pic genererà il formato Big Endian. (Se c’è la necessità di avere il formato Little Endian è semplice aggiungerlo; fammi sapere!) 

· Se viene selezionato PGM8 (1 byte PGM) oppure PPM ma l’originale ha più bit per pixel allora il bitrange viene determinato da 'Bitselect' (es., vengono utilizzati bit 9...2, o 8...1 o 7...0 ). 

· RAH ("Rob Alblas HRPT Format) contiene tutti i canali, ed ha lo spazio per aggiungere file Kepler, etc. Visualizzabile con il mio programma wsat e con l’HRPTReader di David Taylor. 





Modo linea di comando.

Utilizzo: 

 xrit2pic [options]

  options:

  -h                       questo file di aiuto
  -e                       esempi da linea comando
  -overlay_files           mostra file overlay disponibili
  -nogui                   modo linea di comando
------------------------------------------------

    options for locations:

      -src <path>          percorso sorgente dei file XRIT (def.: vedi file-ini)

      -dest <path>         percorso directory di destinazione (def.: vedi file-ini)

------------------------------------------------

    Opzioni per I formati dei file:

      -pgm                 genera PGM  (vedi sotto per default)

      -pgm8                genera PGM (forzato a 8 bits pp)

      -jpg                 genera JPEG (vedi sotto per default)

      -rah                 genera RAH da AVHRR

      -nolin               non linearizzare AVHRR

      -overwrite           sovrascrivi file esistenti (default: no)

------------------------------------------------

    Opzioni per scegliere cosa generare:

      -europe              solo la parte europea (MSG)

      -gmap                mappatura'plane carre (geostaz)

      -movie               genera filmati
      -sat <sat_source>    converti solo questi sat (MSG1, MET7...)

      -type <H or L or A>  converti solo questi tipi (HRIT/LRIT/AVHRR)

      -chan <chan_name>    converti solo questo canale
      -segm <range>        converti solo questi segmenti
      -date <yy-mm-dd>     converti solo questa data
      -time <hh:mm>        converti solo questa ora
      -pro                 estrai anche il file prologo
      -epi                 estrai anche il file epilogo
      -inv                 inverti
      -temp                genera mappatura temperature (solo IR)

      -anagl [anagl_opts]  generate anaglyph

         anagl_opts: <shft[:lmin[-lmax]]>

                           shft:  pixel-shift sinistra/destra (def. 20)

                           lmin:  max shift at this lum  (def. 0)

                           lmax:  min shift at this lum  (def. 512)

------------------------------------------------

    Opzioni per composizioni multicanale:

      -compose [type]      crea immagini con falsi colori
                           type=opzionale; vis o airm o dust or fog

                                vis=default

      -hrvlum              usa HRV per lum (colori high-res)

      -inv <channame>      inverti questo canale
      -lmin <val>          minval; questo valore mappato su 'nero' 

      -lmax <val>          maxval; questo valore mappato su 'bianco' 

      -inv <channame>      inverti questo canale
      -r <channame>[=val]  usa questo canale per il rosso
      -g <channame>[=val]  usa questo canale per il verde
      -b <channame>[=val]  usa questo canale per il blu
                           val=-100...100 (def. 100)

      -ro <offset>         offset per il rosso (def. 0)

      -go <offset>         offset per il verde (def. 0)

      -bo <offset>         offset per il blu (def. 0)

      -msb <msb>           msb per conversione 10 bits->8 bits

                           <msb>=9, 8 o 7

------------------------------------------------

    Altre opzioni:

      -test                non genera, mostra cosa succede
      -log                 genera file log 'xrit2pic.log' (in dest. dir)

      -ol[=<lum>] [<type>] aggiunge i contorni alle foto
                           <lum> = luminosità overlay, 0..255 (def. 255)

                           <type> = coa(st), cou(ntry),

                                    l(atlong), b(oth) (b=default)

Formati generate per default: Vedi File generati.

Per le opzioni -chan, -date e -time sono permessi caratteri jolly. 

Nel modo da linea di commando i file xrit possono essere convertiti immediatamente in file JPEG/PGM . 

Esempio:

  xrit2pic -nogui -type H -chan VIS* -segm 3-7 -date 04-02-* -time 21:00 -pro 

Questo convertirà tutti i file HRIT con i canali VIS* (VIS006, VIS008), segmenti da 3 fino a 7, di febbraio 2004 alle ore 21:00, assieme ai loro file di prologo. 

Il file log, se viene generato, verrà sistemato nella directory di destinazione. Nota che questo file non verrà sovrascritto; le nuove informazioni verranno sempre aggiunte. 

Assicurati di avere accesso in scrittura nella directory di destinazione! Altrimenti non succederà nulla, ed il file log non sarà creato (perché questo file dovrà essere creato nella directory di destinazione). 

Vedi Esempi da linea di comando. 



Utilizzo di due PC.

Xrit2pic può venire utilizzato in un ambiente a due PC, ma attualmente ha alcune limitazioni. 
In questo capitolo vengono elencati tre sistemi, ed una dettagliata descrizione delle impostazioni per uno dei sistemi. 

I due computer hanno le seguenti funzionalità: 

1. PC ricevente (R): 

· Equipaggiato con sintonizzatore Skystar2  

· Software Tellicast 

· Opzionale: xrit2pic per eliminare i dati non necessari 

2. PC di elaborazione (P): 

· Connessione con il PC ricevente
· Software xrit2pic per elaborare I dati 

Ci sono diversi metodi per utilizzare due computer: 

Metodo A: (vedi sotto le dettagliate finestre di regolazione)

· Sul PC 'R' xrit2pic elimina solamente i dati non desiderati (facoltativo) 

· Sul PC 'P' xrit2pic legge i dati dall’harddisk 'R' del PC 'R' atraverso una connessione e scrive i risultati sull’harddisk 'P' del PC 'P' 

Metodo B:

· Sul PC 'R' xrit2pic elimina i dati non desiderati 

· Sul PC 'P' vengono copiati i rimanenti dati RAW dal PC 'R' 

· xrit2pic legge i dati raw da 'P' e scrive i risultati sullo stesso od un altro hard disk sul PC 'P' 

I vantaggi in confronto al metodo precedente è che il sistema di copia può girare a bassa priorità, c’è così minore possibilità di perdita di segmenti. Anche perchè, i dati raw vengono letti una sola volta dall’hard disk 'R'. 

Metodo C:

· Sul PC 'R' xrit2pic converte i dati raw in immagini nei formati standard, e cancella tutti i dati raw 

· Sul PC 'P' vengono copiate le immagini dal PC 'R' 

· xrit2pic legge i dati (in immagini standard) dall’hard disk 'P' e scrive il risultato sullo stesso hard disk 'P' 

Vantaggi: L’elaborazione è veloce (la decompressione dei file Wavelet richiede molto lavoro del processore). Svantaggi: File enormi (se viene usato il formato PGM) o perdita di dati (se viene usato il JPEG) 
(Nota: Lavorando od aggiungendo formati compressi senza perdite con meno di 10 bit per pixel.) 

Il metodo B è attualmente il metodo migliore: nessuna perdita di dati prima dell’elaborazione, e file relativamente piccoli. share


Regolazioni per accesso remoto (Linux).

Se Linux sta girando su entrambi i PC puoi fare un collegamento remote usando sshfs: 

  Se non è disponibile installa sshfs. Es. fedora: 

· yum install fuse-sshfs

(come root, certo). 

  crea un punto di ingresso, es.: 

· mkdir /mnt/msg

  Cerca l’indirizzo IP e l’utente della macchina remota, es. 192.168.1 40 e abcd 

  Cerca la directory dove vuoi entrare, es. /home/abcd 

  Entra nella directory remota: 

· sshfs abcd@192.168.1.40:/home/abcd

Ora puoi navigare a /mnt/msg, e da quì a tutte le sottodirectory (con le protezioni settate correttamente). 



Regolazioni per accesso remoto (Windows).

Metodo A usando Windows.

In breve, se i tuoi file sono nel tuo PC di ricezione in: 
  C:\aa\bb\cc
allora devi renderli condivisibili: 

  C:\aa\bb
ed in xrit2pic sul PC elaborante tu puoi trovare i file sul PC ricevente in: 

  \\rec_pc\bb\cc
(dove rec_pc è il nome della rete del tuo PC ricevente). 

Ora in dettaglio:
Assumendo un installazione standard di Tellique, es., directory di ricezione è:
Programmi\T-Systems\BusinessTV-IP\received
sul tuo PC ricevente. 

· Sul PC ricevente: Setta la directory 'BusinessTV-IP' come  'Condivisa': 

· Naviga fino a Programmi\T-Systems 
· Clicca con il tasto destroy sulla directory 'BusinessTV-IP' e scegli  'Proprietà' 

· Clicca sulla linguetta 'Condivisione' 

· Nel riquadro 'Condivisione di rete e protezione:' attiva 'Condividi'. 

· Clicca su OK. 

Controlla che la directory sia condivisa: 

· Vai a 'Risorse di rete'. 

· Scegli dal menu "Visualizza -> Dettagli". 

· Controlla che 'BusinessTV-IP' sia presente sotto 'Rete locale'. Nella seconda colonna puoi vedere il percorso di questa directory:
\\pcname\BusinessTV-IP (dove pcname è il nome del tuo PC ricevente). 

· Sul PC di elaborazione: 

· Avvia xrit2pic e vai alla linguetta 'Ricevuti'. 

· Digit ail percorso remote nel campo 'Directory to add':
\\pcname\BusinessTV-IP\received 
Nota che questa è lo stesso nome della directory trovata sul  'PC ricevente' sotto 'Risorse di rete', ma con la directory received aggiunta. 

· Clicca su "Carica selez." (pulsante in basso sulla finestra).
Ora il contenuto della directory sul 'PC ricevente' remoto sarà visibile nella finestra principale. 

· Se vuoi salvare queste regolazioni: Torna indietro alla linguetta 'Ricevuti' e clicca su 'Salva'. 

Nota: La directory resa condivisibile ('BusinessTV-IP' in questo esempio) NON è raggiungibile da xrit2pic, ma le sottodirectory ('received' in questo caso) lo sono. Questa è la ragione del perchè la directory contenente received è resa condivisibile, e NON la stessa received! 

Cosa lavora in modo remoto:

  Visualizzazione/conversion dei dati xrit. 

Cosa può non lavorare in modo remoto: (da testare)

  Spostamento (archiviazione) di file dal PC ricevente a quello  utilizzato per l’elaborazione. 

  Archiviazione di qualsiasi tipo 

  Eliminazione di file sul PC remoto 



Regolazione directory.
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Se nessuna directory viene definita verrà usata quella di defaults. 

Definire la directory con file XRIT: 

· Scegli 'XRIT dir list' (vedi nella parte superiore della finestra). 

· Clicca su 'Sfoglia' e naviga per cercare la directory. 
Clicca su 'OK'. 

· Clicca su 'Aggiungi'. 

· Ripeti se debbono venire aggiunte alter locazioni. 

· Scegli una directory dalla lista delle locazioni. 

· Clicca su 'Carica selez.' Per caricare il contenuto della directory. 

Adesso il programma si sposterà nella finestra principale, ed il contenuto della directory selezionata sarà visibile. 

Alcune note: 

· Sfogliare le directory può richiedere del tempo,  se contiene file XRIT. Questo perchè queste directory contengono un grosso numero di file (più di 10000 dopo un giorno di ricezione). 

· Come alternativa, la directory può venire scritta nel campo 'Directory to add'. Ogni volta che un separatore di directory viene digitato ('/' o, per Windows, '\') il contenuto della directory verrà aggiornato. 

· E’ possible utilizzarlo via rete. Per Window, digitare la prima parte del percorso nel campo 'Directory to add', es.: 
\\computer_name\c\
(Nota: NON digitare ':' dopo il nome del disco!) Dopo aver digitato l’ultimo '\' il contenuto della directory del computer remoto viene esaminato e reso visibile, e la navigazione è possibile normalmente. 



Preferenze.

xrit2pic salva le sue regolazioni in un file di preferenze xrit2pic.ini. Questo include le regolazioni di directory discusse nella sezione precedente. 
Puoi tornare alle regolazioni di default cliccando sul pulsante 'Load defaults'. 
Salva le regolazioni cliccando su  Salva '. Nota che la lista delle directory (vedi Directory setting) viene salvata assieme, includendo la directory selezionata! 
Se il programma viene riavviato leggerà il file di preferenze ed immediatamente caricherà la directory che è stata precedentemente selezionata e salvata nel file preferenze. 
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· Window height: Altezza totale della finestra di xrit2pic in pixel. 

· Font size: Grandezza del testo. 0=default=120. (Notea: Possibile che questo non funzioni bene con Linux! Questo deve essere risolto.) 

· Memory usage: Minimize: Per default, l’immagine completa viene mantenuta in memoria dopo aver cliccato 'Vedi (Preview)'. I vantaggi sono che il ridisegno ed il salvataggio sono veloci (non è necessario rileggere i dati o decomprimerli). Lo svantaggio è che si necessita di maggiore memoria. Nota che un immagine HRV richiede 124 Mbyte di memoria! Se viene selezionato Memory usage: Minimize l’immagine non viene tenuta in memoria. Così, il ridisegno ed il salvataggio sono più lenti. (Nota: Se vengono generate file JPEG I dati in memoria non vengono utilizzati, i vantaggi di velocità non ci sono in questo caso.) 

<hr size=3 width="100%" align=center> 
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  Update: 

· cycle: ciclo di ripetizione in secondi 

· Show channel: Determina quale canale visualizzare durante l’aggiornamento. Se e vuoto vengono mostrati tutti i canali. Sono permessi caratteri jolly, es.: VIS* 

  AVHRR mode: Selezionare solo se usato in combinazione con MSG Data Manager. 

  Delete old files: Definisce l’età dei file che debbono essere eliminate utilizzando la voce di menu "File->Elimina". 



[image: image16]
  Viewer programs: In questa schermata può essere definite un visualizzatore da utilizzare (uno per i file JPEG, uno per PGM). Viene assunto che il visualizzatore accetti il file immagine come argomento. 
Per ogni visualizzatore possono venire definite delle opzioni per assicurare che l’immagine venga sempre visualizzata "diritta". 

Se non viene specificato nessun visualizzatore vengono utilizzati quelli entrocontenuti: 

· Linux: 

· per JPEG: xv, reverse-scan option: -record 180 

· per PGM: wsat, reverse-scan option: -sn 

· Windows: 

· per JPEG: i_view32, reverse-scan option: /rotate_r /rotate_r 

· per PGM: i_view32, reverse-scan option: /rotate_r /rotate_r 

Nell’esempio: 

· Per jpeg viene usato xv. Il commando eseguibile è: 
xv file.jpg 

· Per pgm/ppm viene usato wsat. Il commando eseguibile è: 
wsat -w 500 -h 500 -i file.pgm 

· per avi è usato mplayer. Il commando eseguibile è: 
mplayer -fps 3 file.avi -loop 0 & 

Nota: Se nessuno  '%s' viene aggiunto al nome del file verrà aggiunto come ultimo argomento al programma. Se '%s' è presente allora questo sostituirà il nome del file. (Confronta in questo esempio avi e pgm.) 
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  Correct scan direction: Se non viene selezionato le immagini vengono salvate così come vengono trasmesse. Es. le immagini MSG vengono trasmesse da sud-a-nord, così i file salvati MSG saranno sottosopra. Se viene selezionato allora i file PGM/PPM generate saranno sempre 'Dritti'. Vedi anche il pulsante Flip in Preview. 
Nota: I file JPEG saranno sempre come sono trasmessi (es., i file MSG e MET saranno sottosopra, formati stranieri dritti). 

  Auto export prologue/epilogue. Se la casella 'pro/epi' è attivata quando viene esportato un canale verranno esportati anche i relativi file di prologo ed/o epilogo.
  Overwrite. Cosa fare se un file generato esiste già. I file generati hanno un nome univoco, che utilizza ora e canale. Ci sono tre metodi per sistemare le cose con nomi di file già esistenti (Vedi 'Overwrite') 

· Chiede il permesso di sovrascrivere 

· Sovrascrive sempre; non chiede 

· Non sovrascrive mai; non chiede (risultato: il file NON verrà generato. Se è selezionato Vedi verrà lanciato il visualizzatore che leggerà il file già esistente.) 

  HRV full globe: Se selezionato, genera HRV con dimensioni 11136x11136 

  Movie encoder program: Definisce il commando per eseguire un encoder, per generare filmati. 

Se non viene definito nessun encoder verrà utilizzato mencoder: 

· mencoder mf://%s -o %s -mf type=jpeg -ovc lavc -lavcopts vodec=msmpeg4v2 

Un opzione di velocità può venire definita separatamente; per default questa è: 

· -mf fps=1 

Il risultato è una velocità del filmato di un fotogramma per secondo. Se viene utilizzato un commando differente assicurarsi che questo comando contenga 2x %s; xrit2pic rimpiazzerà il primo con il file di partenza, il secondo con il file di uscita. 

  Depth channel for Anaglyphs: 

· Channel: Questo viene utilizzato per informazioni di profondità, se il pulsante Dpthchan nella finestra Preview è selezionato. 

· Invert: Se selezionato il canale di profondità viene invertito prima che venga usato per le informazioni di profondità. Necessario se viene utilizzato un canale IR. 

  Europe boundaries (confini): 

· Definisce posizione (offset_x,offset_y) e dimensioni (width,height) per l’immagine geosazionaria da mostrare se la casella 'Europe' è selezionata. 

· Cambia il nome del pulsante "europe" se necessario. 

· Premi 'Default' se vuoi i confini europei contenuti nel programma. 

Nota: Qualsiasi parte del disco terrestre può essere selezionata in questo modo. 



[image: image18]
· Definisci directory destinazione: 

· Clicca su 'Browse dest. dir'. 

· Sfoglia fino a trovare la directory dove I file generate dovranno essere archiviati. 

· Clicca OK in file manager.
(La directory destinazione può essere digitata manualmente nel campo 'Destination directory'.) 

· Spunta 'Split destination dir' per salvare file di tipo differente nelle loro rispettive directory. (MSG, METOP, NOAA, DWDSAT etc.) 

· Definisci directory sorgente: 

· Clicca su 'Browse src dir'. 

· Naviga fino alla directory dove Tellique scarica i suoi file. 

· Clicca OK in file manager.
(La directory può essere digitata manualmente nel campo 'Source directory'.) 

Nota: Questo è un altro modo per determinare la directory di origine; Vedi anche Regolazione directory. 
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· Definisci file Norad (Kepler): 

· Digita il nome del file (default: weather.txt). 

· Clicca su 'Search', per vedere se il file viene trovato. Vedi linguetta 'Misc' in preferenze per le locazioni disponibili di questo file. 

· Formattazione nome file: 

· Non selezionare 'Use fileformat' per utilizzare il sistema automatico di generazione per i nomi dei file. 

· Seleziona 'Use fileformat' e digita un formato specifico per definire un sistema personalizzato. 

La finestra mostra i codici da aggiungere al formato. Alcuni esempi: 

	formato 
	Esempio risultato 
	commento 

	immagine 
	picture.jpg 
	Sempre lo stesso nome file 
	%s%c_%t 
	MSG1VIS006_061220_1200.jpg 
	


Il default time/date spec "%t" può essere sostituito da personalizzati time spec. La formattazione verrà fatta in accordo alla funzione-C strftime(), eccetto per i seguenti codici % : 
%k, %s, %c, %n, %r, %t
Alcuni codici: 

       %a     Il nome abbreviato del giorno della settimana in base a quello locale in corso.

       %A     Il nome intero del giorno della settimana in base a quello locale in corso.

       %b     Il nome abbreviato del mese in base a quello locale in corso.

       %B     Il nome intero del mese in base a quello locale in corso.

       %C     Il numero del secolo (anno/100) come intero di 2 digit. (SU)

       %d     Il giorno del mese come numero decimale (da 01 a 31).

       %D     Equivalente a %m/%d/%y. (Solo per Americani.   Gli Americani
              noteranno che nei loro Stati la notazione %d/%m/%y è meno comune.

              Tenere presente che in un contest internazionale questo formato è ambiguo
              E non dovrà essere utilizzato.) (SU)

       %e     Come %d, il giorno del mese come numero decimale, ma l’inserimento di uno zero
              Viene sostituito da uno spazio. (SU)

       %H     L’ora come numero decimale utilizzando il sistema a 24 ore (da 00 a
              23).

       %I     L’ora come numero decimale utilizzando il sistema a 12 ore (da 01  a
              12).

       %j     Il giorno dell’anno come numero decimale (da 001 a 366).

       %p     Entrambi  \x{2018}AM\x{2019}  o  \x{2018}PM\x{2019} in base al valore di orario, od alle
              Stringhe corrispondenti per quello locale in corso.  Mezzogiorno viene trattato
              come \x{2018}pm\x{2019} e mezzanotte come \x{2018}am\x{2019}.



Salvataggio/ripristino dell’interfaccia grafica (GUI).

Per le seguenti finestre lo stato della GUI può venire salvato o ripristinato dopo l’avvio: 

· Finestra principale (linguetta  'Base', includendo il menu 'Vedi dopo esport.') 

· 'Lista di conversione' (eccetto la scelta dei canali) (pop up dopo aver cliccato 'Esport.' or 'Vedi' se vengono selezionati canali multipli) 

· 'Canali da mantenere' (pop up dopo aver cliccato 'Elimina' nella finestra principale 'Nuovi file') 

Per salvare lo stato della GUI: 

· Assicurati che la finestra di cui vuoi salvare lo stato grafico sia aperta, e che tutti i pulsanti siano nello stato desiderato. 

· per 'Canali da mantenere (Channels to keep)' devi abilitare 'Elimina' per cambiare le selezioni; dopo potrai deselezionare 'Elimina'. 

· Dal menu Edit scegli 'Preferenze' e clicca 'Salva GUI'. 

Il file è salvato in xrit2pic.gini nella directory corrente. Come xrit2pic.ini può venire archiviato in alter locazioni; Vedi Regolazioni 



Appendice.

Installazione.

Questa è una lista di tutti gli elementi necessary o relativi perchè xrit2pic possa funzionare: 

	categoria
	nome 
	necessario 
	aggiornamento 
	Dove trovarlo 

	Programma principale 
	xrit2pic(.exe) 
	sempre 
	Ogni nuova versione 
	http://www.alblas.demon.nl/wsat 

	libreria 
	GTK 
	sempre
	mai 
	http://www.alblas.demon.nl/wsat (Windows) 

	libreria
	JPEG 
	sempre 
	mai
	http://www.alblas.demon.nl/wsat 

	libreria
	Wavelet 
	sempre 
	mai 
	http://www.alblas.demon.nl/wsat 

	File config. 
	xrit2pic.ini 
	no (defaults) 
	- 
	generato da xrit2pic 

	File config. GUI 
	xrit2pic.gini 
	no (defaults) 
	- 
	generato da xrit2pic 

	Programma di supporto 
	bzip2(.exe) 
	solo AVHRR 
	mai 
	http://www.alblas.demon.nl/wsat (Windows) 

	File dei confini 
	met8*.gif etc. 
	Geostat. Meteosat 
	mai
	Eumetsat 

	File Kepler 
	noaa.txt 
	AVHRR lon/lat calc. 
	Ogni mese ? 
	http://www.celestrak.com 


Linux.

L’installazione di xrit2pic è semplice; è solo questione di copiare il programma e le sue librerie nel posto giusto. 

Ci sono due file da scaricare: 

· xrit2pic.gz: il programma 

· decompr.tar.gz: le due librerie 

Si presume che gtk sia installato. Questo è sempre normalmente il caso (che io sappia) su macchine Linux. Altrimenti scarica ed installa gtk-1.2. 

Decomprimi i due file e copiali nella directory es. $HOME/bin. 
Per i file AVHRR è necessario bzip2. Questo è presente in ogni distribuzione Linux. 

Windows.

L’installazione di xrit2pic è semplice; è solo questione di copiare il programma e le sue librerie nel posto giusto. 

Ci sono 4 o 5 file da scaricare: 

· xrit2pic.zip: il programma 

· gtk_dll.zip: 8 librerie dll 

· decompr.zip: 2 librerie dll 

· xrit_install.exe: il programma di installazione. 

· bzip2.exe (necessario per i file AVHRR) 

per gli aggiornamenti è sufficente scaricare xrit2pic.zip, e far partire il programma di installazione. 

Installazione fatta utilizzando l’installer: 

· Assicurarsi che i 3 file zip e xrit_install.exe vengano scaricati nella stessa directory. 

· Avvia xrit_install.exe. 

· Copia bzip2.exe nella stessa directory dove è installato xrit2pic. (non viene sinora effettuato dal programma d’installazione.) 

· Crea un collegamento a c:\Programmi\xrit\xrit2pic.exe 

· Sfoglia fino a trovare il programma, clicca su di esso con il tasto destro del mouse e nella finestra scegli "crea collegamento" 

Installazione: (senza utilizzare l’apposito programma) 

· Crea la directory: c:\Programmi\xrit (se non c’è c:\Programmi prova su un altro disco). 

· Sistema tutti i file zip files in questa directory. 

· Decomprimi i 3 file zip, es. usando winzip. 

· Copia bzip2.exe nella stessa directory. 

· Crea un collegamento a c:\Programmi\xrit\xrit2pic.exe 

· Sfoglia fino a trovare il programma, clicca su di esso con il tasto destro del mouse e nella finestra scegli "crea collegamento" 

Nota: Nelle proprietà del collegamento (seleziona dal menu con il tasto destro) è possibile minimizzare la popup di comando all’avvio di xrit2pic. Anche la directory di lavoro può venire cambiata quì. 



Esempi da linea di comando.

Il prossimo commando converte tutti i file HRIT con il nome di canale che inizia con VIS per ogni giorno con orario UTC 12:00. Solo I segmenti 7 ed 8 vengono aggiunti all’immagine (che è l’Europa). 

xrit2pic -nogui -type H -chan VIS* -segm 7-8 -time 12:00 

Il prossimo è un esempio per fare questa conversione 'sempre'; ogni giorno la directory dei file ricevuti viene ripulita. 

  Script per Linux: 

xrit2pic -nogui -type H -chan VIS* -segm 7-8 -time 12:00 -log

rm /home/user/from_msg/received/*

La partenza è come un cronometro, ogni giorno intorno a mezzanotte (qualche tempo dopo che i file da convertire sono stati generati!) 

  Per Windows: 

xrit2pic -nogui -type H -chan VIS* -segm 7-8 -time 12:00 -log

del c:\from_msg\received\*.*

La partenza viene fatta utilizzando 'Task scheduler'. 



Dettagli sulla generazione dei filmati.

xrit2pic genera filmati nel seguente modo:

· Una directory speciale 'movietmp' viene creata, sotto la directory di destinazione. Se la directory esiste già allora il contenuto verrà spostato in una directory  di salvataggio(nella stessa temp. directory). 

· Tutte le immagini selezionate vengono generate in formato jpeg, in questa temp. directory. 

· Se viene scelto 'Reuse'(riutilizza): 

· Prima controlla se il file con la corretta dimensione esiste già nella directory sav; se è così, questo file viene spostato nella directory temp
· Altrimenti il file jpeg verrà generato dai dati raw. 

· Se viene scelto 'Replace'(sostituisci): (Ri)genera ogni file jpeg. 

· I file jpeg vengono combinati in un filmato formato avi. 

· Se viene scelto 'Remove' (elimina): Tutti I file temporanei vengono rimossi. 

Se viene utilizzato un codificatore esterno 'mencoder' avvengono le stesse cose. 'mencoder' combina tutti I file nella directory temp in un filmato; questa è la ragione del perchè prima tutti i file vengono spostati nella directory sav. Per il generatore di filmati entro contenuto questo non è necessario. 
Il vantaggio del mencoder è che possono venire utilizzati diversi codificatori. Quello di default è msmpeg4v2. 
Le opzioni del mencoder, o persino i suoi comandi, possono essere sostituiti da qualcosaltro; vedi preferenze ed il manuale del mencoder. Così altri codificatori od un differente programma di codifica potranno essere utilizzati. 

Dettagli sulla generazione di anaglifi.

I dati Meteosat non contengono informazioni 3D. per creare un illusione 3D vengono generate due immagini (destra e sinistra) utilizzando la luminanza di ogni pixel. Le nuvole sono chiare ed alte, la terra è relativamente scura e bassa, questo spiega perché la luminanza può venire utilizzata per informazioni di profondità. 
Ogni pixel viene duplicato in rosso e ciano; lo scostamento tra i due è maggiore se la luminanza è bassa ('terra'). 

Regolazioni.

Nella finestra di anteprima in modo Anaglifi ci sono molti pulsanti pop up. 

· Se è necessario un canale speciale per la profondità spunta la casella 'Dpthchan'. (Vedi preferenze per quale canale utilizzare.) 

· Spunta la casella "Init"; digita 'r' per aggiornare la finestra. 

· Regola Lbnd finchè non viene mostrato come i particolari a livello inferiore sono colorati di rosso (digita 'r' dopo ogni regolazione).
Suggerimento: Mari e terreni senza nuvole. 

· Regola Hbnd finchè non viene mostr just ge ato come i particolari a livello superiore sono colorati di verde. 
Suggerimento: le nuvole dovranno essere delle macchie verdi. 

· Deseleziona 'Init" e digita ancora 'r', per aggiornare. 

Se devi aggiungere confine/linee di costa: 

· Spunta 'Overlay' nella finestra principale. Questo produrrà delle line bianche dei confine e delle coste. L’effetto 3D è che I confini sembrano fluttuare ad una certa altezza. 

· Spunta "OL_3D" se i confini dovranno apparire a livello del terreno. 

· Regola la brillantezza del confine utilizzando OL_lum. (Specialmente in 3D i confini non dovranno essere molto luminosi.) 


Gli anaglifi sono possibili per le immagini in bianco e nero e per quelle a colori, così come anche per i filmati. Le immagini in bianco e nero daranno i risultati migliori per gli anaglifi. 



Installazione di mencoder e codificatori (NON necessario se viene utilizzato il visualizzatore interno!)

Installazione di mencoder per Linux.

Scarica mplayer ed i codecs dal sito:
Mplayer 
Installazione di  mencoder per Windows.

Vai sul sito
Mplayer e scarica MPlayer-mingw32-1.0pre5.zip
Copia mencoder.exe in una directory nel percorso di ricerca (es. c:\windows). 

Vai sul sito
codecs e scarica win32codecs-essential-20040703.tar.bz2
Decomprimi e dll files into c:\windows\system. 



Alcune note.

I file generate possono essere enormi; Le immagini HRV intere sono di 5568 x 11136. Se hai esperienza di problemi con i visualizzatori per carenza di memoria puoi provare wsat. Questo programma is able to show picpuò visualizzare immagini di dimensioni virtuali infinite su piccoli computer. (L’inconveniente è il ridisegno dell’immagine, es. dopo una zoommata, è un po’ lento.) Non può leggere jpeg, così dovrai convertire i file in formato PGM se vuoi utilizzarlo. (la dimensione di un file HRV in formato PGM è di circa 124 Mbytes). 



Informazioni sul programma.

xrit2pic è scritto in C e C++, usando: 

· GTK per le parti grafiche 

· IJG (Independent Jpeg Group) codice per la decompressione JPEG 
· Codice Eumetsat per la decompressione Wavelet 

