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Kicad versie 7, 8
Een korte handleiding, met alleen de basis.

1 KiCad startscherm
Hier kunnen basisinstellingen zoals paden naar libs worden aangepast/toegevoegd, zowel voor 
schema (symbolen) als voor PCB (footprints). Zie menu direct onder Preferences, niet onder 
Preferences->Preferences. Deze instellingen kan je ook bereiken/aanpassen via Preferences onder 
'Schematic editor' resp. PCB editor.

• Configure paths
◦ hier kunnen symbolische namen (indien nodig) van (gedeeltelijke) paden naar libs 

toegevoegd worden, bv.:
▪ Onder Name: KICADTEST 
▪ Onder Path: /home/ralblas/proj/.../lib/

• Manage Symbol Libraries (kan ook later in 'Schematic Editor'): 
◦ hier worden library-files(!) gedefinieerd (je kan in het pad-deel de bij 'Configure paths' 

symbolische namen gebruiken)
◦ In tab 'Global Libraries' staan de standaard-libs, normaal evt. zelf libs toevoegen
◦ In tab 'Project Specific Libraries': libs die specifiek alleen voor het huidige project nodig

zijn:
▪  regel toevoegen ('+' onderaan)



▪ Library Path: pad+file  invoeren, dus:
${zoekpad}/<rest_pad>/<file>.lib (zoekpad gedefinieerd bij Configure paths)

• Manage Footprint libraries (kan ook later in PCB Editor)
◦ hier worden paden(!) naar locaties van libfiles (files met definitie footprint) 

gedefinieerd. (Dus hier niet de lib-files toevoegen!)
◦ Verder op dezelfde manier eigen libs toevoegen als bij 'Manage Symbol Libraries'.

Voor spoorbreedtes enz. zie 3.1 Voorbereiding



2 Schematic Editor

2.1 Teken het schema
• Component toevoegen:

◦ toets 'a' 
◦ of 'opamp'-symbool rechts 
◦ of menu "Place -> Add symbol"

▪ boven evt. filter intypen, bv. con voor connectors
▪ component kan uit meerdere symbolen bestaan, bv. 7400: 4x nand + voeding

• Verbinden: 
◦ toets 'w'
◦ of 'zwarte schuine draad' rechts 
◦ of Place -> Add wire 
◦ of cursor bij pin-einde houden waarvandaan een verbinding moet komen

▪ Let op: verbinding over andere aansluitpunten: dan zijn die ook aangesloten!
▪ Evt verbinden via labels in plaats van verbinden met draden:

• 'l' of Place -> Add label, naast label zit een'connector', die op draad zetten
• Verticaal herhalen (bus):

◦ teken stukje draad aan bovenste pin, de andere kant is dus los
◦ Met toets 'Insert': wordt actie herhaald op positie hieronder, als daar een pin 

zit; de draad is dan automatisch verbonden met die pin
◦ label aan bovenste draad, naam eindigen met cijfer (index), bv. a1 of a(1)
◦ Met toets 'Insert' wordt  actie herhaald, index wordt auto opgehoogd
◦ voor aanpassen van deze 'repeated items' zie Preferences->Prefecernces, 

'Editing options'
▪ draden met afwijkende spoorbreedte, bv. voeding:

• Place -> Add  Net Class Directive
◦ bij 'Value' een naam invullen, bv. power, wordt later bij 3.1 Voorbereiding 

gebruikt.
◦ Aansluiten op betreffende verbinding (dat geldt dan ook voor alle draden die 

hiermee zijn verbonden, direct of via labels)
◦ geef GND-draad een label: 'l' of Place -> Add label, op draad zetten
◦ niet-aangesloten pin van een component: 

▪ toets 'q' 
▪ of rechts, klik op 
▪ of Place -> Add No Connect Flag

• bevestigingsgaten:
◦ Place->Add Symbol
◦ MountingHole_Pad (dit geeft extra verbinding tussen onder- en bovenvlak die aan GND 

zitten (zie bij PCB).

2.2 Footprint toevoegen aan iedere component

• Onder menubalk, icoon  , "Run footprint assignnment tool" geeft tabel met 3 
kolommen:



◦ links lib, rechts onderdelen uit de geselcteerde lib, midden de onderdelen aanwezig in 
het schema.

◦ bv. 14-pins IC: 
▪ links: selecteer Package_DIP
▪ midden: selecteer betreffende component
▪ rechts: selecteer Package_DIP:DIP-14_W7.62_Socket (of bv. SMD-variant)
▪ dubbel-klik hierop, footprint wordt nu in midden getoond achter component
▪ Let op dat de juiste component is geselecteerd voordat je dubbel-klikt! Het is erg 

makkelijk om een eerder toegewezen footprint zonder dat je het ziet te overschrijven 
als die in middelste kolom buiten beeld is!

◦ Herhaal dit voor alle componenten, ook voor bevestigingsgaten:
▪ bv. MountingHole_3mm_Pad_Via (geeft montagegat van 3 mm, en een extra goede 

verbinding tussen boven- en ondervlak).
◦ Ook aan zelf toegevoegde componenten moet zo een footprint worden toegekend.

2.3 Checken
• Inspect -> Electrical Rules Checker

◦ Run DRC
▪ Dit geeft mogelijk een foutmelding als een Net Class is toegevoegd, bv. power. Die 

verdwijnt als de betreffende net class is gedefinieerd, zie 3.1 Voorbereiding



3 PCB Editor 
Er wordt hier uitgegaan van printenmaker JLCPCB ([1]. Alternatief: oshpark [2] (wel veel duurder) 
Voor de laagste printkosten moeten de afmetingen max. 100x100mm zijn (mag nog iets groter zijn, 
4x4 inch). Kosten zijn dan slechts ca. 5 euro voor 5 stuks print, incl. verzendkosten.

3.1 Voorbereiding
N.b. Er zijn 3 rijen menu's in dit scherm:

1. normale menu's
2. iconen
3. extra menu's

• Aanpassen lijndiktes: menu (rij 3)
◦ Track: use netclass width -> Edit Predefined sizes 
◦ of

▪ Design rules, Net classes: 
• default: track width: 0,4 mm
• voeg extra regel toe met naam power (zie hoofdstuk 'schema'!) en aangepaste 

lijnbreedtes enz. (track width: 0,8 mm) 
• (Eventueel, niet aan te raden, kan je de min. thermal relief spoke, onder 

Constraints, op 1 zetten (geeft mogelijk in sommige gevallen te hoge 
overgangsweerstand van pin naar grondvlak!))

• Grid: menu (rij 3)
◦ zet op een niet te lage waarde, bv. 0,254 inch; dat maakt het makkelijker om de 

componenten netjes te plaatsen.
• GND: in plaats van verbinden met sporen kan een grondvlak worden gedefinieerd die dan 

ook voor die verbindingen zorgt. De tekst GND wordt in het schema aangegeven (zie 2.1 
Teken het schema) en in PCB gebruikt (zie 3.2 Tekenen).

3.1.1 Enkele eisen JLCPCB (printmaker):

3.2 Tekenen

3.2.1 Componenten

• Update PCB with changes:   of Tools -> Update PCB from Schematic



• plaats met hand onderdelen
• maak PCB-rand:

◦ rechts, layers: kies Edge.Cuts onder Layers
◦ selecteer door klikken op rechthoek en teken (2x klikken links-boven/rechts-onder)
◦ afmetingen bepalen: helemaal onderaan is dx/dy te zien, die kan je op 0 zetten mbv de 

spatiebalk.

• maak boven/onder GND-vlak indien gewenst: (zie 2.1 Teken het schema, opmerking label 
GND)
◦ menu Place=>Add filled zone
◦ klik op een te plaatsen hoekpunt, geeft venster Copper Zone Properties

▪ kies hier links F.Cu, B.Cu, en onder Net 'GND' 
▪ Eventueel rechts-onder Remove islands: Always selecteren, dit voorkomt geisoleerde

grondvlakken (vanwege eromheen gerouteerde sporen).
▪ OK, maak omtrek (normaal gesproken over de PCB-rand), maak af met dubbel-klik
▪ Goed kijken dat er geen schuine zijdes bij zitten; leg de hoekpunten precies op de 

PCB-rand. Eventueel hoekpunt aanklikken en met ingedrukte muistoets verplaatsen.
◦ Let op: laat het deel onder een eventuele WiFi-antenne vrij (geen grondvlak, geen 

onderdelen).

3.2.2 Tussentijds checken

• Inspect -> Design Rule Checker
◦ Om overlap teksten enz. te checken (er zijn nog geen sporen dus die foutmeldingen 

negeren)

3.2.3 Sporen

• Handmatig verbinden:
◦ indien boven/onder GND-vlak: routeer alles behalve GND-sporen, of:

• Autoroute:
◦ File -> Export Specctra DSN ==> .dsn-file
◦ start freerouting (apart te installeren programma, zie appendix)
◦ negeer java.lang.NoClass... melding
◦ Select the design file: <file>.dsn
◦ Confirm importing stored rules: Y

▪ dit zijn o.a. spoorbreedtes gedef. in PCB Editor)
◦ klik "Start auto-router", routeren begint. Dit duurt hooguit een paar minuten.
◦ File->Export Specctra Session File ==> .ses file
◦ Terug naar PCB:

▪ Import Specctra Session (de .ses file)
• als boven/onder GND-vlak was gedefinieerd: Edit->Fill zone (of 'b')
• aanbrengen niet-gerouteerde lijnen

◦ verbinden GND-vlakken met spoortje: dan bij DRC 'refill all zones' uit zetten!

3.3.3 Slots

Als op een print hoogspanning voor komt (bv. 220V): zorg dat er tussen het 220V-deel en de rest 
een sleuf in de PCB komt. Dit doe je door met layer Edge.Cuts een rechthoek te tekenen op de 
betreffende plaatsen. Dit is dus een afbakening binnen de "Edge.Cuts" die om de hele PCB is 
getekend. Max. lengte: 5 mm, breedte 1 mm. (5mm = max zonder extra kosten JLPCB)



3.3 Checken:
• inspect -> Design Rule Checker

◦ In pop-up: zet 'refill all zones' uit!
◦ Dan: "Run ERC"
◦ Unconnected: handmatig proberen te verbinden, evt. al gerouteerde lijnen aanpassen

▪ Soms moet een spoortje tussen 2 grondvlakken worden aangebracht, als die niet 
verbonden waren. Dat kan met een extra spoortje, zonder via's (ziet eruit als een los 
spoortje).

◦ Melding "Error: Thermal relief connection to zone incomplete":
▪ Dit betekent dat verbinding van een pin met spoor mogelijk niet goed genoeg (te 

hoogohmig) is. Oplossing:
▪ extra verbindinkje leggen van pin naar grondvlak (dus i.h.a. een heel korte 

verbinding)
▪ Of Tools->Add Teardrops
▪ Of, als je de melding en check niet wilt (niet aan te raden): zie Design rules, 

Net classes

3.4 Wijzigingen aanbrengen:

• Edit->Unfill All zones
• aanpassen> verbindingen, plaatsing componenten enz.
• Edit->Fill All zones
• Ook bevestigingsgaten plaatsen, als type Pad_Via: met GND verbinden (niet nodig als 

onder/boven GND-vlak is gedefinieerd)

3.5 Speciale zaken

• Array van pads (bv. experimenteerveldje)
◦ plaats pad links-boven:

▪ Place->Add Footprint
• SolderWirePad_1x01_Drill1.5mm
• properties: pad-diameter : 1.5, hole: 0.7

◦ selecteer met rechter-muis, kies Create from selection, Create Array
◦ vul in hor. count, vert. count en spacing
◦ OK



4 Gerber bestanden en opsturen

4.1 Aanmaken bestanden
In PCB Editor:

• File -> Fabrication Outputs -> Gerbers:

Dit is voor dubbelzijdig. Enkelzijdig, zonder doormetallisering:
◦ selectie weghalen voor: F.Cu, F.Mask

• Klik op Plot, dit geeft de gerber-files.
• Klik op Generate Drill Files:

• Klik op 'Generate Drill File', dit geeft de info over te boren gaten.



• Er zijn nu de volgende bestanden gegenereerd: (extensies)

enkelzijdig dubbelzijdig

kopersporen achter -B_Cu.gbl -B_Cu.gbl

kopersporen voor *) -F_Cu.gtl

pads achter -B_Mask.gbs -B_Mask.gbs

pads voor *) -F_Mask.gts

tekst achter (vaak niks) -B_Silkscreen.gbo -B_Silkscreen.gbo

tekst voor -F_Silkscreen.gbo -F_Silkscreen.gto

rand van de print -Edge_Cuts.gm1 -Edge_Cuts.gm1

te boren gaten .drl .drl

*) Wel doormetalliseren, verder niet dubbelzijdig: deze ook selecteren?

Maak een zip-file met alle 6 (enkelzijdig) of 8 (dubbelzijdig) bestanden.

Eventueel check in Gerber Viewer:
• vanuit Kicad hoofdvenster, open de Gerber Viewer
• File -> Open Zip Archive File 

Check dat alles aanwezig is!

4.2 Opsturen naar JLCPCB
• Gebruik de zip-file met 6 of 8 bestanden
• Ga naar https://jlcpcb.com/
• Klik op 'Order now':

• Add Gerber file, kies de zip-file
• Check, als het goed is hoeft er niets aangepast te worden:

◦ basismateriaal: FR4
◦ Build Time: 2 days
◦ Calculated price: $2.00

• Save to cart -> in winkelwagentje
◦ je moet een account hebben; evt. aanmaken en inloggen

• winkelwagentje:
◦ Secure checkout
◦ Shipping Method: IOSS, Global Standard Direct Line ==> $2.28 kosten
◦ Pay directly
◦ Kies bv. Paypal ==> 0,50 paypal kosten



Totale kosten zijn dan: $4.78

Overzicht settings:



Appendix

Programma's
• KiCad:

◦ https://www.kicad.org/download/
• freerouting: voor Linux, mac en windows:

◦ https://github.com/freerouting/freerouting/releases

Libs: toevoegen en maken
Ontbrekende componenten kunnen worden toegevoegd, te vinden bij:

• https://www.snapeda.com
• github

Of zelf maken:
• met symbol editor resp. footprint editor (niet getest)
• libs zijn ASCII, je kan ze aan de hand van een voorbeeld zelf maken (intypen):

◦ .lib (schemasymbool)
◦ .kicad_mod (footprint)

Om even een grof idee te geven:
Schema: vb.: text, een pin, een lijn

DEF xxx U 0 40 Y Y 2 F N
F0 "U" 0 0 50 H V C CNN
F1 "xxx" -450 2100 50 H V C CNN
DRAW
T 0 20 0 100 0 0 0 & Normal 0 C C
S -800 2000 -100 -100 0 1 0 N
X Qdec    A1   -900 1800 100 R 50 50 1 1 I
ENDDRAW
ENDDEF

Footprint:  vb.: text, een pin, een lijn

(module xxx (layer F.Cu) (tedit 65699AE7)
  (fp_text value yyy) (layer F.Fab)
    (effects (font (size 0.701239370079 0.701239370079) (thickness 0.15)))
  )
  (pad A1 thru_hole circle    (at -11.43 -21.59) (size 1.2 1.2) (drill 0.8)(layers *.Cu *.Mask))

  (fp_line (start  13.97  26.67) (end  13.97 -26.67) (layer F.SilkS) (width 0.127))
)

N.b. Er zijn meerdere formaten, bovenstaand is oud maar wel bruikbaar in nieuwere Kicad versies.

Referenties
[1] https://cart.jlcpcb.com/quote
[2] https://oshpark.com/home
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